Because of this bug https://bugs.launchpad.net/mir/+bug/1238695 Ubuntu Touch on the Google Nexus 7 (grouper), Touch randomly freezes, and flickers.

It is bad enough that I cannot do anything except restart the device.

I was just wondering how to workaround this, can I switch back to the "surfaceflinger" that Touch previously used - as this was working nicely on previous versions?

  • to anybody that's encountering the "needs to be root" line when you run the above command in adb. break up the line. i ran "adb shell" first, then "adb su" and then" "rm -f /home/phablet/.display-mir && reboot" and it worked – user1778741 Dec 28 '13 at 9:58
up vote 8 down vote accepted
+50

Connect your Nexus to your Ubuntu desktop machine, check if it is connected with

adb devices

(a line "[device ID] device" should be returned) and then issue the commands

adb root

(maybe it tells you that you're already 'root') and

adb shell rm -f /home/phablet/.display-mir && adb reboot

I just did it successfully. Of course, the fallback to Android's surfaceflinger is not a fix but it's a temporary workaround.


Alternatively, run

adb shell
su
rm -f /home/phablet/.display-mir && reboot

This is a bug with Mir on that device. It has already been reported, but you can workaround the problem by deleting the file ~phablet/.display-mir on the device, and restarting it. This will switch the display server back to SurfaceFlinger, so the device can be usable until the bug is fixed.

  • Where can we find that file at? – user203775 Oct 17 '13 at 20:33
  • 1
    Exactly as specified in the answer. It is under the phablet user home directory as .display-mir. – dobey Oct 18 '13 at 1:24

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.