7

Just finished upgrading from Ubuntu 13.04 to 13.10. Everything works fine. After the installations, I restart to finish the installations. In the log in screen, I put my password and then it goes back to the log in screen. I've tried so many times, still the same.

Note: Using Unity, running 13.04 before using MacBook Air with single OS.

2
  • Same here. Please help.
    – Randy Tang
    Oct 17, 2013 at 16:34
  • I saw a quick-flash message: "Could not acquire name on session bus" after entering the password and hitting <enter>.
    – Randy Tang
    Oct 17, 2013 at 17:05

6 Answers 6

5

I had the exact same issue after upgrading from 13.04 to 13.10.
None of the solutions here worked for me, so I found this bugreport. I removed Cinnamon/Nemo with sudo apt-get remove --purge cinnamon* and sudo apt-get autoremove and now everything works fine.

0
3

I had the same issue. Tried cinnamon didn't work. Read about the permission issue on the .Xauthority file. Sorry, I lost the link to that answer

  1. Logged in with Ctrl+Alt+F1 as the user

  2. and removed the .Xauthority file

  3. went back to GUI session by Ctrl+Alt+F7

Worked like a charm!!

2
  • 1
    It would be nice if you could look up where the file is located and edit the post to add it in. Jan 4, 2014 at 9:37
  • @JulianStirling it's in your home folder (~) May 27, 2015 at 20:07
0

I could temporary get past this problem by changing from Ubuntu Default to Cinnamon, at least it lets me access the files. Really wondering why is it Unity's broken...

1
  • This is not really answering the question for the OP unless he also has cinnamon installed as well. Perhaps you can rewrite the post to have it answer the question better?
    – gertvdijk
    Oct 17, 2013 at 17:22
0

At the login screen press CTRL+ALT+F1 and login as normal user, then execute:sudo su
No errors should happen (if errors happens write them here!) and your prompt will be with an "#" character at the end, you are root now: don't do stupid things and run exit to return a normal user.
After this check let's reconfigure your login manager, execute: sudo dpkg-reconfigure gdm and, eventually, select gdm as your default login manager.
Execute sudo killall Xorg; after that you will be asked to login (if don't press CTRL+ALT+F7) without any error: try to login.
If it still don't work, press CTRL+ALT+F7, run passwd and change the password; execute sudo killall Xorg and try to login with the new password.
If it still doesn't work (damn! :-) ) return to the virtual terminal and execute rm ~/.Xauthority, then sudo killall Xorg and try to login.
The password asked with "sudo" is your user password, never forget your password.
If the login still doesn't work, it's a more complicate case, report here any error.

6
  • When I type CTRL+ALT+F1, Login as normal user and type sudo su and dpkg-reconfigure gdm and it tells me that gdm is not install. by the way, Ubuntu 13.10 comes with 3.11 Kernel right? why am i list as 3.9?
    – user203648
    Oct 17, 2013 at 17:30
  • Well, no luck. Root check was OK. But I was not able to make any selection during reconfiguring gdm. The system just showed "/usr/sbin/dpkg-reconfigure: gdm ..." and then returned to the prompt. Also, nothing happened when pressing CTRL+ALT+F7; is "F7" correct?
    – Randy Tang
    Oct 17, 2013 at 17:58
  • Follow all the solutions you provide, none of them works.
    – user203648
    Oct 17, 2013 at 18:10
  • **user203648: run uname -a to know what kernel you're using. Run on a terminal sudo apt-get install gdm and reboot. **Tang: yes, dpkg-reconfigure MAY offer you a choice if more than one compatible login manager is installed; CTRL+ALT+F7 is correct (Xorg goes on tty7 by default; more instances WILL go to tty8,9 ecc.), maybe you didn't start Xorg. Follow the procedure another time, if doesn't work (try others CTRL+ALT+Fn) execute cat /var/log/Xorg.0.log|grep WW and cat /var/log/Xorg.0.log|grep EE, the post here the errors. It's an interesting problem. Oct 18, 2013 at 6:58
  • On behalf of user hewhocutsdown: I tried everything you said, to no avail.
    – Seth
    Oct 22, 2013 at 21:31
0

I had that same issue, i was not having cinnamon installed. Just the default Ubuntu desktop environment. After looking for alternatives without success, i did the following that fix my problem.

  1. Since it is impossible to login back with Unity, i took the decision to install cinnamon on it (which will break Unity)

  2. At the login screen press CTRL+ALT+F1 and login as normal user.

  3. Type in the following commands:

    sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
    sudo apt-get update
    sudo apt-get install cinnamon
    
  4. After installing all the necessary packages, just log out and change the log-in option to Cinnamon.

  5. You should be able to log into your system now with Cinnamon.

I believe the problem is with Unity, can't find out how or why but a great fix to that issue will be awesome.

0

I had this problem this morning just after running some regular updates - I tried all sorts of things like deleting .Xauthority etc but in the end I tried reinstalling my nvidia driver which seemed to fix the login screen problem.

http://www.boliston.com/2014/01/11/ubuntu-13-10-login-screen-problem/

Not the answer you're looking for? Browse other questions tagged or ask your own question.