I'm completely new to Ubuntu I downloaded and unpacked a tar.gz package, after extraction, it is said in its documentation : "type ./configure --disable-gts"

But when I run this command alone it tells me "Permission Denied" error. Then I tried to use sh ./configure --disable-gts instead, but this time I faced this error:

> configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.

How can I overcome these two problems? (I mean permission and compile error) I'm just a rookie and I need urgent help.

  • Most new users do not need to compile from source as many programs either exist in the software centre or there is a ppa or deb package available. Tell us what you are trying to do and we may be able to recommend an easier way to install it. Also provide a link to what you downloaded so if you do have to install from source we can give detailed instructions. – Warren Hill Oct 17 '13 at 16:34
  • Where did you download / unpack the archive to? these kinds of execution issues often occur if you are trying to run commands on an NFTS or FAT partition – steeldriver Oct 17 '13 at 16:37
  • @ Warren Hill and @steeldriver I'm trying to solve a scientific problem numerically by the use of the package which i downloaded. this solver is written in C++ hence its modules should be compiled in order to run. I will bring the whole documentation in the next comment. – Ali.A Oct 17 '13 at 16:51
  • To compile, follow these steps (in which I assume only a passing familiarity with linux/unix): 1) Save the file lbflow-1.1.tar.gz in a directory where you have write privilege. 2) Open a terminal window and navigate to that directory 3) upack with the following command (note that '>' indicates the command prompt, you don't type it!): > tar -zxf lbflow-1.1.tar.gz This will produce a directory called lbflow-1.1 4) Navigate to the new directory with: > cd lbflow-1.1 5) Configure and build with: > ./configure --disable-gts > make > make docs – Ali.A Oct 17 '13 at 16:52
  • possible duplicate of How to compile source code from a tarball? – dobey Oct 17 '13 at 16:52

The problem is almost certainly because you are trying to run the configure command on an external drive that does not support Unix-style executable permissions.

Although it is possible to mount some non-Linux drives with execute permissions, the easiest solution will be to copy the archive to somewhere in your actual Ubuntu home directory and try again there.

If you are trying to save disk space in your home directory you can keep the actual tar.gz file on the external disk.

  • Thanx steeldriver for your answer and guides :) But i gained no results even when i copied the whole folder to my /home directory. I finally used "sh ./configure" rather than "./config" and it worked! but i faced anpther problem with "make" command that i will ask in another question and will tag you in order to see my question. (I afraid some moody person give me another negative vote just because of asking questions!) – Ali.A Oct 17 '13 at 20:56
  • Probably because you unpacked the archive on the external device first and then copied the folder, the configure script's execute permission got lost - instead of using sh it likely would have worked if you set the file's execute permission and then did './configure' as per the original instructions. Or you could have unpacked the archive again in your /home dir. – steeldriver Oct 17 '13 at 21:05
  • I would give it a try. This is my next error : askubuntu.com/questions/360529/error-using-make-command I would be appreciated if you take a look at it too – Ali.A Oct 17 '13 at 21:14
  • I have just commented on your new thread - I suggest you start over and unpack the tar.gz file again in your home dir instead of using the folder you copied from the external drive – steeldriver Oct 17 '13 at 21:18
  • had this problem trying to run ./configure from synced folder (Vagrant on OS X). copying files to /home on VM made all the difference :) – Rok Jarc Mar 8 '15 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.