1

When creating a New Project in NetBeans, it hangs on the creation screen;

Screenshot

I'm running Netbeans 7.0.1 on Xubuntu 13.04.

Java -version prints:

java version "1.7.0_25"
OpenJDK Runtime Environment (IcedTea 2.3.10) (7u25-2.3.10-1ubuntu0.13.04.2)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

/usr/lib/jvm/ contains the following folders;

java-1.5.0-gcj-4.7-amd64  java-6-openjdk-amd64   java-7-openjdk-common
java-1.6.0-openjdk-amd64  java-6-openjdk-common
java-1.7.0-openjdk-amd64  java-7-openjdk-amd64

I tried editing /usr/share/netbeans/7.0.1/etc/netbeans.conf with the following (as was suggested in another post);

netbeans_jdkhome="/usr/lib/jvm/java-7-openjdk-amd64/jre/"

But that didn't work. Instead, NetBeans then presented an error on the loading splash when it reached "Turning on Modules..." claiming the JDK was missing.

Both NetBeans and the OpenJDK Java 7/6 Runtimes were installed through the Ubuntu Software Centre. I've also tried uninstalling and reinstalling both Java and NetBeans.

Any help would be greatly appreciated, thanks!

0

Managed to solve it.

Uninstalled both OepnJDK versions and installed the Oracle JDK via the instructions found here.

NetBeans now runs fine, seems it only has problems with OpenJDK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.