I set up a new Ubuntu laptop, 13.04, purpose: media download and storage server in a multi-OS/device household. I have an NTFS partition called "storage". I've had all kinds of permission errors, and programs unable to create directories, etc. I read this post and got my NTFS partition working beautifully:

Setting permission for NTFS partition

Wherein I was given instructions on umask and fstab. Worked great.

Now I'm still having problems with external shares. I have twos shares that I can access as graphical Ubuntu folders just fine. I click browse network, I click Windows Network, I click my workgroup name, and click the server name (having successfully entered the username and password), and so on, to the folder I want. I even have them mounted, so they appear on the sidebar. If I drop one of the folders into terminal, it interprets like this: smb://a300/._share

My Sickbeard service wants to create folders and move files from my ubuntu machine into this share, into a folder called TV. When configuring sickbeard or similar services, if I try to navigate there via graphical folders, I have to go there like this: /run/user/misterfantastic/gvfs/smb-share:server=a300,share=share/TV/

My various download services do not like that path or the permissions or both. They complain the locations don't exist or that they can't write to them, you name it.

I'm thinking the way to do this right is to use fstab, and make them so they appear in my media folder. Am I right? I've tried numerous ways of adding them to fstab but none of them works. I get an error message like this:

sudo mount -a
mount: wrong fs type, bad option, bad superblock on //,
   missing codepage or helper program, or other error
   (for several filesystems (e.g. nfs, cifs) you might
   need a /sbin/mount.<type> helper program)
   In some cases useful info is found in syslog - try
   dmesg | tail  or so

If I run that command I see this:

    misterfantastic@dualboot:~$ dmesg | tail

[95366.948432] CIFS VFS: No username specified
[95503.366728] RPC: Registered named UNIX socket transport module.
[95503.366731] RPC: Registered udp transport module.
[95503.366733] RPC: Registered tcp transport module.
[95503.366734] RPC: Registered tcp NFSv4.1 backchannel transport module.
[95503.419335] FS-Cache: Netfs 'nfs' registered for caching
[95503.457031] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[95578.021641] CIFS VFS: No username specified
[96191.990091] CIFS VFS: CIFS mount error: No usable UNC path provided in device string     or in unc= option!
[96274.660907] CIFS VFS: CIFS mount error: No usable UNC path provided in device string     or in unc= option!

Here's an example of the line I wrote in fstab:

smb://a300/a300ii /media/misterfantastic/a300 cifs credentials=/home/misterfantastic/.smbcredentials,iocharset=utf8,sec=ntlm 0 0

And the contents of the credentials file:


Please help me in fixing this.

UPDATE: I'm reading and trying everything I can, but to no avail. I keep bouncing from one error to the next.


Solution given by OP in the question:

Installed cifs-utils

sudo apt-get install cifsutils

Installed winbind

sudo apt-get install winbind

in .smbcredentials I added a line for domain= (my actual workgroup name)

I finally around with the IP address and folder name until something stuck and didn't throw off errors. It was //(ip address)/foldername altered the line in stab to look like this:

//(local ip)/foldername /media/misterfantastic/a300   cifs    credentials=/home/misterfantastic/.smbcredentials,uid=misterfantastic,gid=misterfantastic,iocharset=utf8,sec=ntlm,  0   0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.