I need a little help trying to install a Wacom Intuos tablet, model number CTL-480/S. My installation of Ubuntu 13.04, 64bit, doesn't seem to be able to detect the device. I've tried an few different USB ports on my machine and get the same result.

I believe there is an issue because when I open the System Settings app from the launcher and browse to the Wacom Tablet section under hardware, it reports that there is 'No table detected'.

When I use lsusb I can see the device is detected:

Bus 003 Device 004: ID 056a:030e Wacom Co., Ltd

I've also pulled the following from the syslog:

Oct 16 16:51:05 earth kernel: [ 7062.388031] usb 3-5: new full-speed USB device number 4 using ohci_hcd
Oct 16 16:51:05 earth kernel: [ 7062.611038] usb 3-5: New USB device found, idVendor=056a, idProduct=030e
Oct 16 16:51:05 earth kernel: [ 7062.611042] usb 3-5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Oct 16 16:51:05 earth kernel: [ 7062.611045] usb 3-5: Product: Intuos PS
Oct 16 16:51:05 earth kernel: [ 7062.611047] usb 3-5: Manufacturer: Wacom Co.,Ltd.
Oct 16 16:51:05 earth mtp-probe: checking bus 3, device 4: "/sys/devices/pci0000:00/0000:00:02.0/usb3/3-5"
Oct 16 16:51:05 earth mtp-probe: bus: 3, device: 4 was not an MTP device

I'd really appreciate any suggestions to help debug and install this device.

  • Thanks, I've tried to provide a little more context, see above, as you've suggested. Oct 16 '13 at 15:59
  • Looks a lot better! +1. Too bad I am unable to provide an answer (I don't have such a device here at hand.)
    – gertvdijk
    Oct 16 '13 at 18:32
  • Exactly the same problem on Fedora 19 on my new tablet a few minutes ago. Same tablet, dmesg clearly identifies it. Do you get a wacom driver loaded if you check via lsmod?
    – Caleb
    Oct 17 '13 at 0:58
  • I've run lsmod and cannot see a wacom driver loaded. Tempted to give upgrading to Ubuntu 13.10 a chance. Oct 17 '13 at 14:09
  • 2
    This forum post indicates support for this model is in the next (as yet unreleased) driver version.
    – Caleb
    Oct 17 '13 at 18:22

Im running Ubuntu 13.10, I downloaded the kernel driver v0.20 and followed instructions from Linux Wacom SourceForge Project, and my CTL-480 is working flawlessly.


EDIT: According to this forum post new drivers that support this device were released a few weeks ago. I don't know what the status on these drivers is in Ubuntu yet but they have turned up in ArchLinux and some other places and you can always install them manually while you wait on distro releases.

The CTL-480 tablet is not supported by the currently released wacom input driver for Linux. Support for the model has been added to the code base and is expected to be in the 0.20 version of the driver (0.19 is current as of this writing). Device IDs and other things have also been submitted to the linux kernel so that they are properly recognized in the future.

I don't have an ETA for support, but expect this to work out of the box in the coming months.

In the mean time it will only work if you manually compile the drivers after applying the various patches submitted for supporting this model.

  • xserver-xorg-input-wacom is 1:0.20.0-0ubuntu1 in Ubuntu 13.10 - would that mean it is supported in 13.10? Oct 24 '13 at 8:14
  • @Vadi version 0.20 didn't come out with support for these tablets until December 6th. I don't know what you are looking at but I suspect that is an OLD version of the xorg driver (current is 0.23), not the new version of the kernel driver.
    – Caleb
    Dec 27 '13 at 13:00
  • That interesting, according to the Ubuntu Software Centre, I'm running xserver-xorg-input-wacom 1:0.20.0-0ubuntu1. When I plug the CTL-480 tablet into my machine, it isn't detected by the Wacom Tablet tool in the System Settings application. Dec 28 '13 at 12:26
  • @mjwittering You are confusing the XORG input handler with the kernel device driver. They are two separate components and versioned independently. You may not have a separate package at all for the device driver as is is likely rolled in your kernel package. On Ubuntu I expect this to be taken care of in the next kernel package release (although your xorg package might need to be 0.23 as well).
    – Caleb
    Dec 28 '13 at 14:18
  • 1
    @mjwittering The latest kernel is currently 3.12.6, so no, not by a long shot. That being said distros like Ubuntu tend to run a few versions back most of the time due to their testing cycle but they sometimes backport device drivers. I don't know what version is current for your distro release or when you will see the drivers come down the pipe.
    – Caleb
    Dec 28 '13 at 18:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.