89

I want to share the wireless Internet connection on my desktop with my old laptop, through ethernet.

I have ticked the option "Make available to others" on both connections, on my desktop, but my laptop doesn't connect. Am I doing something wrong or is it a bug?

  • Before checking software configurations... how are you connecting the two PCs? If directly, you need a crossed cable (do they exist anymore?). See en.wikipedia.org/wiki/Ethernet_crossover_cable. Otherwise you'll need at least a bridge... – Rmano Oct 16 '13 at 15:52
  • I have done the exact same thing on 12.04 before. I am thinking there is a problem with network manager since i have Gnome 3.10 and it got updated today. – Christos Baziotis Oct 16 '13 at 18:03
  • 6
    @Rmano: According to that article, modern Ethernet hardware auto-negotiates so crossover cables are not needed. I've also done this before with ordinary Ethernet cables. – Mechanical snail Oct 30 '13 at 1:25
  • 1
    @Mechanical snail: thanks, I didn't noticed that. So I suppose I can dispose my precious manually connected cross-over cable :-) – Rmano Oct 30 '13 at 15:37
  • possible duplicate of Share Wireless connection with Wired Ethernet Port – bcbc Nov 29 '14 at 21:51
101

On the server computer:

  1. On the computer, which is connected to the Internet, click the network icon in the panel and go to "Edit Connections..." at the bottom of the menu.

    Edit Connection...

  2. Double click your Wired Connection (Leave your wireless connection untouched, the one connected to Internet and the one you want to share, as I understand).

    Network Connections Dialog

  3. On the "IPv4 Settings tab", select Method: "Shared to other computers"

    Editing Wired Connection

  4. Reconnect by clicking on the Wired Network, so it gets a new IP address. (The two computers must be connected by an ethernet cable for this step, so connect them now if you haven't already.)

  5. Click on "Connection Information" in the network menu and write down the IP address and network mask (in my case it was assigned 10.42.0.1/255.255.255.0 but I do not know if that will always be the case).

    Connection Information

On the client computer:

  1. Go to "Edit Connections..." and assign a "Manual" Method. Assign an IP address on the same subnetwork (10.42.0.69 for example) and put the IP and network mask you wrote down in "Netmask" "Gateway" and "DNS servers"

    Editing Client Wired

  2. Reconnect to the network to let the new settings be assigned.

  3. Pat yourself on your back and surf away!!!

  • 9
    The first 4 steps were enough in my case (Ubuntu 14.04). What is wrong with the automatic assignment (DHCP)? Why are you manually reassigning it? – toto_tico Dec 6 '14 at 22:54
  • If i try to put wired and wifi network in same network, and configure wired network with manual it will it work ? – Ankur Loriya Jan 10 '15 at 17:39
  • 1
    This should be marked as the correct answer! :) – jackyalcine Sep 20 '15 at 18:36
  • 2
    I've done this dozens of times. Just use auto instead of manually assigning it on the non-server computer and don't forget to leave ports 67, 68, 52 and 53 open for dhcp and dns access. Also, don't forget that ufw blocks incoming, so you will have to either disable it on the server computer or set the rules accordingly. – mchid Sep 23 '15 at 0:10
  • 4
    This solution worked fine for me. The only think I would like to add is: If the method "Shared to other computers" is not listed on the configuration menu from IPV4 tab (this was my case running Ubuntu 17.10 with default Gnome interface) you can start the network settings from the command line with nm-connection-editor. As seen here. – leomilrib Jan 19 '18 at 18:08

protected by Community Jun 6 '15 at 4:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.