14

There was an update for Google Chrome today, and it wasn't installable due to unresolved dependencies. How can I correct this?

Screenshot of Synaptic

3
  • I have the same problem... but only lib32gcc1...
    – lilicus
    Commented Oct 18, 2013 at 15:57
  • @lilicus I think that's because you have libxss1 installed
    – Silviu
    Commented Oct 21, 2013 at 21:08
  • This was an issue with the Chrome repositories. The issue was fixed and solutions doesn't apply.
    – Braiam
    Commented Oct 23, 2013 at 17:37

4 Answers 4

8

See, I am also having this problem, and I did a little research of my own to see what the issue was. Also, I have the same exact errors that were posted.

As it turns out, the Google Code Developers for 32-bit Ubuntu/Debian Google Chrome "made a goof," and accidentally added those dependencies which are of 64-bit architecture, and inaccessible by 32-bit Ubuntu/Debian. The 64-bit program is working fine, as it turned out.

All we can do is wait until another update comes out that will fix this issue; I am currently waiting patiently, using Chromium as my backup. Make sure to update/install when a new Google Chrome version is released as it will possibly--and hopefully--fix this issue.

If you can not wait, I have read that the unstable/beta version of Chrome does not have this issue as it was resolved during the development of this new version. You can download it here.

I would only download that if you can not wait or use another browser until the stable update comes out.

source: Google Chrome update won't install due to unmet dependencies

1
4

You have probably encountered this bug: Wrong 64-bit dependencies on 32-bit version of Ubuntu. It's being worked on.

All I can suggest is that you keep watching that bug's progress and stay on your current version until it's well and truly fixed. There are a few comments there indicating that it's fixed but then look at a more recent bug report which has been merged into #304017, which is why I'm suggesting patience. If you wish, just sudo untick the Google Chrome ppa in your Software Sources for now. You can re-enable it whenever you wish.

3

Try this.

Download dummy packages:

wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32gcc1_4.7.3-1ubuntu1_all.deb
wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32stdc%2B%2B6_4.7.3-1ubuntu1_all.deb
wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/libc6-i386_2.17-0ubuntu5_all.deb

Then install them:

sudo dpkg -i lib32gcc1_4.7.3-1ubuntu1_all.deb lib32stdc++6_4.7.3-1ubuntu1_all.deb libc6-i386_2.17-0ubuntu5_all.deb

Then you can install Google Chrome:

sudo dpkg -i google-chrome-stable_current_i386.deb
2
  • Working for me. But it is not bad for future automatic updates of this packages? Commented Oct 19, 2013 at 4:35
  • 1
    Good question. But anyway these packages cannot be installed on 32-bit Ububntu in normal way so I think they won't be updated in normal way too.
    – Max K
    Commented Oct 19, 2013 at 12:13
0

I was experiencing exactly the same problem, on two different 32-bit 12.04 machines; see Unable to select Chrome updates on Ubuntu 12.04

However, I can report that as of noon EST on 23 Oct 2013, the problem seems to be resolved for me. The Chrome update could be selected, and it installed successfully.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .