I'm suffering from the issue that xine is always starting up muted so that I have to manually increase the volume. I tried all options (with Configuration experience level set to maximum). The startup audio volume is set to 60% and tried with restore volume level at startup both enabled and disabled as well as all other settings I could find.

This started already quite a while ago, I think with Ubuntu 8.04 and seems to be caused by Pulseaudio. Removing ~/.pulse helps and xine starts up non-muted once but further starts are muted again after the directory is recreated. It links to the /tmp folder which is a tmpfs RAM disk, so it is deleted at every reboot, but this doesn't

This happens on two installations on quite different computers (Acer Aspire 7720G Laptop and Dell Omniplex 745). I'm using the normal xine v0.99.6 and running Ubuntu 10.10 64bit. I tried googling it several times in the last two years but never found anything relevant. I thought it might be caused by an old wrongly updated pulseaudio config file, but it also happens with a fresh installation. The home directory is the same, but I deleted all pulseaudio related user config files I could find and this didn't changed anything.

Deleting ~/.xine doesn't change anything apart of the Xine config window popping up at the first start afterwards. Running pulseaudio -k will make xine start officially muted (Volume at 0%) but with normal sound!

  • What happens if you try removing ~/.xine ? – user14547 Apr 19 '11 at 23:01
  • @wiplash: See my updated question. – Martin Scharrer Apr 22 '11 at 11:29
  • It seems to be much better with 11.04. There xine starts non-muted most the time. – Martin Scharrer May 6 '11 at 15:09
  • 1
    Ugh, I hate this bug. The only Xine instance I've ever had that doesn't do it is one that is using ALSA pass-through on a SPDIF port with audio.device.alsa_front_device:default and audio.output.speaker_arrangement:Pass Through in the config. – Kees Cook Sep 23 '11 at 5:30
  • @KeesCook: It works for me now with 11.04. – Martin Scharrer Sep 23 '11 at 7:58

I also found that audio.pulseaudio_device:auto also works. Perhaps anything explicit works, which would imply there's something wrong with the code that is supposed to set the default when there is no config file entry.

| improve this answer | |

Modify this string in the ~/.xine/config file:



| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.