7

I have a DVD which I can open in Windows, but in my Ubuntu 12.04 installation I cannot any more. I receive this error:

Unable to mount UDF Volume

Error mounting: mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

What should I do to open it? Do I need to install anything?

  • How do I actually write to the UDF disc? – neverMind9 Oct 31 '18 at 0:34
8

Open the terminal and try mounting the DVD with:

sudo mount -t udf /dev/sr0 /cdrom

The argument following the -t is used to indicate the filesystem type, which in this case is udf. UDF or Universal Disk Format is an operating-system-independent file system commonly used on DVD and other digital media.1

1https://en.wikipedia.org/wiki/UDF

  • 1
    The answer also works when instead of physical DVD you have a file on disk that's a DVD image (maybe downloaded from somewhere). Then you just replace /dev/sr0 by the file's pathname. That was my problem today and your answer solved it. – Silvio Levy Jan 24 '17 at 3:07
3

Not all DVDs are really udf, if the -t udf doesn't work (wrong superblock) try:

sudo mount -t iso9660 /dev/sr0 /cdrom

that is after sudo mkdir /cdrom so the /cdrom directory exists.

~$ sudo mount -t udf /dev/sr0 /cdrom
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog -
       try `dmesg | tail`  or so

~$ sudo mount -t iso9660 /dev/sr0 /cdrom
mount: block device /dev/sr0 is write-protected, mounting read-only
~$ ls /cdrom
autorun.inf  casper  EFI      isolinux    pics  preseed             ubuntu
boot         dists   install  md5sum.txt  pool  README.diskdefines  wubi.exe

*Yet it is a DVD+R

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.