1

I have changed the names of some photos in my collection, but Shotwell is still remembering old names of mentioned images.

I tried changing shotwell's directory names to force it to generate a new configuration file/directory/db with no luck.

Removed and re-imported my photo collection from a different directory, but Shotwell still remembers old names.

Purged Shotwell, manually deleted Shotwell files in .local and .cache then reinstalled it again, but Shotwell still remembers old image names.

Any suggestions?

  • Shotwell version 14.01
  • Ubuntu version 12.04 LTS
3
  • Hope bleachbit or Computer-Janitor would help you.. – Saurav Kumar Oct 14 '13 at 23:56
  • I think that the metadata of the images is what shotwell is showing you. Try in another system and you will see the same results. – Braiam Oct 15 '13 at 0:03
  • Thanks, but basically Nautilus is showing correct image info, after the change I made, but Shotwell still showing info prior to changes. Tried in Gthumb too which is reading correctly photo names and new metadata from Exif info. It's Shotwell issue , and so far I was unable to remove old metadata and image names no matter I wiped out all shotwell dates and folders when reinstalling it. – danijelc Oct 15 '13 at 11:43
2

Normally Shotwell does not modify the photos, but stores added meta-data in it's own database: ~/.local/share/shotwell/data/photo.db[.bak].

If deleting that doesn't remove the titles, then it may be updating the exif information; the option to do this is located in preferences, under the first tab (Collection). You can tell by right-clicking one of the files in question in Nautilius, and reading the content of the image tab.

You may want to look at a tool like jhead to strip the info if that is the case.

5
  • Ty @Bryan, but I'm not sure if I understood. Nautilus shows correct name and metadata for each of photos. When checking metadata or files names with other software its ok too. Only Shotwell shows old metadata and file names etc, This wouldn't be problem if when wiping out shotwell would really delete everything shotwell related. I believe there is some other Shotwell related files beside the ones in '.local' and '.cache' and I'm unable to find em and start the shotwell from zero. – danijelc Oct 15 '13 at 11:57
  • The titles should be in plain text, so have you tried grepping for them? e.g. 'grep -Rn "known title" ~/' – Bryan Agee Oct 15 '13 at 15:32
  • Sory but not sure if I'm following? Would you mind to explain. thx – danijelc Oct 16 '13 at 1:16
  • 1
    First, find a photo with one of the offending titles. Then, copy that title exactly. Open a terminal (ctrl+alt+t), and type the command: grep -Rn {paste your text here} . ; that should list any files with that text in them. – Bryan Agee Oct 16 '13 at 17:02
  • 1
    This comment open my eyes. I didnt solve the issue with shotwell but I come out where problem is. Shotwell remember photo description in exif as photo name if description was added through Shotwell (even more in my case, changing name of photo in shotwell actually changed exif description and not name), however I did not find way to force Shotwell to read names instead exif description but using grep as mentioned in your comment I were able to find all photos with wrong description and delete descriptions. Thus Shotwell now reads photo names. Thank You Bryan! – danijelc Oct 18 '13 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.