I am pretty sure there are three other links that report the same problem, I am getting

I am following this link to compile my custom Kernel


Tools you'll need To start, you will need to install a few packages. The exact commands to install those packages depends on which release you are using:

Hardy (8.04):

sudo apt-get install linux-kernel-devel fakeroot kernel-wedge build-essential

When I try the above packages the fakroot, kernel-wedge, build-essentail all seem to be accesible by terminal except for the linux-kernel-devel.

$ sudo apt-get install linux-kernel-devel  
Reading package lists... Done 
Building dependency tree         
Reading state information... Done
E:Unable to locate package linux-kernel-devel

I am trying to install Hardy to my ubuntu 12.04.3 LTS, So far I tried

sudo apt-get update && sudo apt-get install linux-kernel-devel 

I even tried to modify the sourcelist and added the universe line to the line below.

deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted

What is that I am missing here? Why is Ubuntu not able to locate the package? I am wired and connected to the internet.

  • You should have read the introduction on bold letters that says "this page would need significant cleaning. You may want to refer to Kernel/BuildYourOwnKernel page in Ubuntu wiki instead which is a cleaner and more up-to-date guide to (simple) kernel building" – Braiam Oct 15 '13 at 13:28
  • @Braiam I did refer to the same doc,but I need to install lucid,hardy(excluding the linux-kernel-devel) mentioned in the link above for the CRDA packages else it was throwing package crda,crda-wireless not found. That was the reason I had to go back to install the above packages. – rao Oct 15 '13 at 16:46

That specific package isn't packaged in Ubuntu 10.04 and up. If you're trying to compile a custom kernel, the correct way to get the prerequisites in Ubuntu 10.04 and later is to run these commands:

sudo apt-get install fakeroot build-essential crash kexec-tools makedumpfile kernel-wedge
sudo apt-get build-dep linux
sudo apt-get install git-core libncurses5 libncurses5-dev libelf-dev asciidoc binutils-dev

Hardy is a completely different version of Ubuntu, and can't be installed to another version. If you need Ubuntu 8.04 (Hardy Heron), you would need to find a copy of it online, download it, then write it to a CD or DVD.

That said, 8.04 is long out of service, and it's recommend to use a newer version of Ubuntu.

  • Awesome Ian. I was hoping to hear that the package is deprecated. I did install 12.X and not the earlier ones, since the doc said that the prerequisite for installing custom kernel is to install hardy and Lucid I was persistent on finding how to do this. – rao Oct 14 '13 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.