103

I have recently installed Ubuntu on my machine and everything has been working fine, except I don't see the Dropbox indicator. I have installed and re-installed Dropbox multiple times and can confirm that it's running in the background (with ps -e | grep dropbox).

Does anyone know how to get it back?

132

Found a solution at the comment #7 from the Ubuntu bug:

  1. Install package sudo apt-get install libappindicator1

  2. Log out, and then log back in (or issue dropbox stop && dropbox start at the command line)

| improve this answer | |
  • 3
    do you have any references? – kiri Oct 15 '13 at 9:57
  • I've tried executing "dropbox stop && dropbox start" automatically after resume using a script I put in '/etc/pm/sleep.d/'. The log says it is working just fine, but the dropbox indicator is still missing. Thus if I want to see the dropbox icon I have to execute this command manually after resume... – king_julien Mar 15 '15 at 14:26
  • In 15.10 installing this extra package makes the Dropbox icon show up in the KDE system tray. – Tom Chiverton Dec 15 '15 at 23:00
7

If I recall correctly there is an unfixed bug in the dropbox package for 13.10. Cf. launchpad. This is at present a confirmed, but unassigned bug.

If this is not that bug, then read this question.

| improve this answer | |
  • Answer in the above publication. – Sardinha Oct 26 '13 at 13:24
6

There is another issue that has popped up recently.
This is with regard to 14.04, being that,

Dropbox runs in the background but does not show the indicator panel icon even when appindicator1 is installed.

The only work around i found was to re-install Dropbox by getting the .deb file form the link: Download Dropbox

| improve this answer | |
  • worker but needed a reboot – Pisu Nov 1 '14 at 10:47
  • This bug also in Debian 8. – Léo Léopold Hertz 준영 Jul 7 '15 at 8:13
  • 1
    I have this problem now , early 2016 and this solution is not working – makkasi Mar 8 '16 at 14:15
5

Thanks to Denilson dropbox stop && dropbox start worked for me - but only until next reboot.

Solved it permanently by writing a short shell script (which i put into /opt directory):

#!/bin/bash
sleep 60s
dropbox stop && dropbox start -i &

(mark as executable) and then click on the Ubuntu button on the left upper corner, type "startup" and there add an entry to call that start that shell script /opt/dropboxrestart.sh.

| improve this answer | |
  • 2
    Nice solution. You can also combine this into one line sleep 60s && dropbox stop && dropbox start & and put directly into command field in Startup Applications – shea Jul 14 '15 at 15:58
  • I have this problem now I'm using SSD instead of hard drive - must be a timing issue as there is no problem when I use hard drive. I found I could not just modify command of dropbox Startup Application because next time dropbox starts, it just overwrites it. Also I had to add a sleep between the stop and start as the stop returns well before it actually stops. I created /usr/local/bin/dropbox_delayed which does sleep 60 && dropbox stop && sleep 60 && exec dropbox startand created new Startup Application DropboxDelayed which has command dropbox_delayed. Works fine for me. – Chris Good Aug 19 '15 at 6:40
  • Also, I could not put multiple commands in Startup Application command i.e. sleep 60 && dropbox stop etc. Does not work (Ubuntu 12.04). – Chris Good Aug 19 '15 at 6:43
3

As of ubuntu 14.04 do this to put dropbox icon on menu bar :

sudo apt-get install nautilus-dropbox

You can start Dropbox from your applications menu.

UPDATE

issue this to view what Ubuntu package is involved

dpkg -l|grep dropbox

... output

ii  dropbox   2015.10.28    amd64   cloud synchronization engine - CLI and Nautilus extension

so now dropbox package description gives mention of nautilus ... so lets view all files listed in that package ... issue

dpkg -L dropbox 

sure enough it lists files which are nautilus related ... so to answer your comment - I would say the normal dropbox package does contain customizations for integration with nautilus so that stand along package nautilus-dropbox is no longer necessary

| improve this answer | |
  • well, I can start it from the menu, but the icon stil does not show up. I guess that is what I get when using beta versions of 14.10 ... – oligofren Oct 5 '14 at 21:02
  • It not solves the problem – deFreitas May 11 '16 at 2:51
  • Can anyone explain the relation between the dropbox package and the nautilus-dropbox package? And as a bonus, the relation of these two to Dolphin and nautilus? – Paul A. Feb 12 '17 at 22:14
1

I've found a nice workaround, as clean as a workaround can be -- but it is just a workaround. I put the critical command "dropbox stop && dbus-launch dropbox start" in my startup file and set the dropbox autostart option to "n" (which might not really be necessary). Now I have the Dropbox icon on the menu bar at the bottom of the screen, and this solution survives a reboot.

| improve this answer | |
  • Awesome, this worked wonderfully (on Kubuntu 14.04.5)! – Autodidact Jul 28 '17 at 15:21
0

I'm on 14.04 with Gnome 3. None of the above solutions did work for me.

A solution that worked finally was to install a gnome extension 'topicons' https://extensions.gnome.org/extension/495/topicons/

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.