I have an Asus laptop with a core i3 processor, 4GB memory and an NVidia 540M graphics card, as well as an Intel graphics card.

I have just installed Ubuntu 13.04 and it is lagging. By lagging I mean being non-responsive for a few seconds even while i'm using the terminal. I have tried updating the drivers via apt-get but it did not do the trick.

Is Ubuntu using the second Intel graphic card and that is why the update did not help?


That's strange. I have an Asus too. It's the same than yours except for the processor, mine has an i5. But Ubuntu 13.04 runs ok. Did you have any problem during the installation? Maybe you should reinstall. The other thing is that you need to install Bumblebee, in order to use the Intel card normally, and not update the graphic cards as usual.

A useful guide here Bumblebee In other case, u should try another distro and see if you have the same problem :) Hope this helps


I think that I have found the issue. It appears that my mouse R.A.T. 3 was causing the delays. After I have plugged in a standard USB mouse the problems resolved. I think that I would need a driver that supports the R.A.T mouse.

Thanks for the help.


Solved the issue completely. I had to run sudo nano /etc/X11/xorg.onf and add the folllwoing:

Section "InputClass"

Identifier "Mouse Remap"
MatchProduct "Madcatz Mad Catz R.A.T.3 Mouse"
MatchDevicePath "/dev/input/event*"
Option "ButtonMapping" "1 2 3 4 5 6 7 8 0 0 0 0 0 0 0 0 0 0 0"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.