0

I have a HP Pavilion dv5-1200eo Entertainment Notebook PC with ATI Mobility Radeon M82/M86/RS780M and I haven't been able to find any working drivers for it.

It is overheating and working poorly. I can't find it on HP.com or ati.com. The drivers I've downloaded fails to install.

Can you direct me to the best driver for my graphics? Help very much needed. I have also installed tlp to no avail. Thanks guys. //Edit No I couldn't install it. But I might have been doing it wrong. I ran sh amd-driver-installer-catalyst-13-4-x86.x86_64.run

jon-are@hp-ubuntu:~$ lspci -nnk | grep -A5 VGA

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV620/M82 [Mobility Radeon HD 3450/3470] [1002:95c4]
    Subsystem: Hewlett-Packard Company Device [103c:3600]
    Kernel driver in use: radeon
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series] [1002:aa28]
    Subsystem: Hewlett-Packard Company Device [103c:3600]
    Kernel driver in use: snd_hda_intel
  • Did it work immediately after installation? What is the output of sudo lspci -nnk | grep -A5 VGA? Edit your question and add the information. – Braiam Oct 13 '13 at 20:29
0

The default radeon drivers are the opensource ones. AMD offers a proprietory, closed-source package named fglrx, one that has improved in quality a lot in the last half year or so, mostly thanks to Valve's Steam efforts on linux.

Try downloading it from here:

http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64

Your best bet is to make an ubuntu package with the installer, and install that. It makes removal or switching between radeon/fglrx a lot easier, and keeps the system clean.

  • How do I make an Ubuntu package with the installer? I'm pretty new to Linux and Ubuntu. – JnPson Oct 13 '13 at 22:27
  • You start the downloaded file and pick this option from the GUI. – Agoston Horvath Oct 15 '13 at 21:41
0

I know this is an old question, but I found it searching for drivers for an old laptop that has an AMD Radeon HD 3200 (RS780M) and the link in the above answer points to an unsupported driver for any GPU under a Radeon HD 5000.

Instead, use this link for the Legacy Catalyst 13.1 driver. http://support.amd.com/en-us/download/desktop/legacy?product=Legacy2&os=Linux%20x86_64

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.