After a reboot, and not after doing anything that could justify this, my Ubuntu 13.04 system is completely dead, in that every time I boot, and after I log in, there's no launcher and no system bar on the top. The desktop looks fine, but there's no way to run any program.

Since the only icon I have on the desktop is, incidentally, an .odt document, I have tried to double click on it, and it opens in OpenOffice Write just fine, but the windows have no borders or title bar.

It looks like the most basic window manager is not running. I don't know whether it's Unity, or Compiz, or what.

The last things I had done before the last boot were:

  • install virtualbox and create a virtual machine
  • sudo apt-get install nvidia-current

So I have entered a virtual terminal and removed both virtualbox and nvidia-current (sudo apt-get remove...), but that hasn't fixed the issue.

My system is completely unusable. I have rebooted three times without luck. What can I do?

I tried:

  1. ccsm -> try to enable the "Unity plugin". It has no checkbox (like the one depicted in the screenshots in other answers), so I click on it as if it was a button, and it leads to a screen where there is a checkbox that says "enable Unity plugin". That issues a warning that another plugin is required, it prompts whether to not enable Unity plugin or enable the other one that is required, I choose the latter, and so on for a couple more plugins. At the end, it is impossible to close the ccsm window, because the "close" button does nothing, and there is no window bar.

    This doesn't change a thing. Even after logging out/in (which I perform by killing xorg) or rebooting, I'm still stuck with an empty desktop with no unity launcher or top sytem bar.

  2. dconf reset -f /org/compiz/ and unity --reset-icons & disown

    Outcome: it vomits dozens of compiz errors (can't init this and that plugin, fatal dunnowwhat, something() unavailable on screen 0, and a lot more) and ends with a segfault. Doesn't fix the issue.

  3. deleted .config/compiz-1 folder tree in my home directory, with or without going to Ctrl + Alt + F1 Didn't change a thing

  4. the farthest I've been able to go is the following, which does get me Unity running but without the nvidia drivers and with only 640x480 resolution:

    • sudo apt-get remove nvidia-304
    • reboot => now my screen is 640x480
    • dconf reset -f /org/compiz/ && setsid unity

    This brings up the loved and familiar Unity shell. However, if I go to System Settings and Display, the only available resolution is 640x480. I guess it is the one my non-nvidia card supports (though it seems pretty strange to me: I thought this computer had an Intel HD4000 GPU which should support pretty good resolutions)

  5. after this, I tried reinstalling nvidia-current (which installs nvidia-304) and then I repeated dconf reset -f /org/compiz/ && setsid unity, but this has the same outcome as (2)

  6. uninstalled nvidia-304 again, and tried with sudo apt-get install nvidia-310, and again reset -f /org/compiz/ && setsid unity Same outcome as (5) and (2).

  • please don't anybody mark this as a duplicate, because none of the answers to similar questions worked for me.
    – matteo
    Oct 13, 2013 at 21:24
  • No, none of those answer worked
    – matteo
    Oct 13, 2013 at 21:25
  • I'm seriously thinking of reinstalling the whole ubuntu (which I had installed only two days ago, anyway), but (1) I'm afraid of screwing up the boot loader, which took me a bit to figure out (uefi bios, ubuntu alongside with Windows 8); and (2) I need to know how to prevent this from happening again at any random moment
    – matteo
    Oct 13, 2013 at 21:28
  • Hey, has somebody edited the title to make me look stupid?
    – matteo
    Oct 13, 2013 at 23:23
  • I don't know why @Braiam deleted all his comments. Then I'm deleting my answers too, as they don't make any sense without the questions
    – matteo
    Oct 25, 2013 at 11:56

3 Answers 3


I incurred a similar situation not so long ago, after trying multiple things what worked was

Ctrl-Alt-t unity-tweak-tool --reset-unity

and restart.

Installing unity-tweak-tool:

sudo apt-get install unity-tweak-tool
  • I only get a huge lot of "compiz (core) - Error: ..." errors (many of them like "Plugin init failed: xxxx" but also a few other ones, and at the end a segmentation fault.
    – matteo
    Oct 13, 2013 at 21:30

You should purge all of the nvidia driver stuff you've installed before, it seems like its a mess:

sudo apt-get purge nvidia*

Then reinstall nvidia-current, reboot and you're good to go:

sudo apt-get install nvidia-current
sudo reboot

Here's what finally fixed it and took it back to how it was before. THANKS TO BRAIAM for the last step, without which everything else was fruitless.

  • sudo apt-get purge nvidia*
  • reboot
  • sudo rm /etc/X11/xorg.conf <<<<< THIS WAS THE KEY
  • reboot

Throughout the process, I did this a few dozens times: - dconf reset -f /org/compiz && setsid unity and - dconf reset -f /org/compiz && unity --reset-icons &disown but these alone never got the issue fixed, so I don't know whether it was relevant together with the rest

I also sudo apt-get install'ed some nouveau-related stuff that I can't find anymore (for some reason it's not all in my bash history) but I think this was irrelevant as the relevant part should have been already installed.

Note that sudo dpkg-recnfigure xserver-xorg NEVER WORKED for me. It either produced a popup window informing of a crash, or no output at all.

The only way I got it fixed was thanks to @braiam who told me to delete /etc/X11/xorg.conf and reboot, which finally fixed it.

If @braiam is willing to write an answer, I will accept that instead of this of mine.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .