0

I just installed Ubuntu on my MSI ge60-20c and recognized the wireless-driver not working well. After some searching I found out it's a common problem and some people managed to get a proper driver working. Though I couldn't find any driver working for 3.8.0-19-generic :(

Can you help me please?

PS: Ubuntu 13.04 - 64 bit

Greets

1
  • Nope, tried that one before....compiling that one gives me more than 1 error which is not fixed by simply commenting out that line!
    – Finnhax
    Oct 13, 2013 at 19:14

2 Answers 2

0

It seems that Realtek's dropbox tarball isn't compatible with Linux 3.8.*. Larry Finger, a noted developer working in the wireless branch of the kernel, has put up a new driver on github.

To download and compile the driver, you need the git software, and packages needed for compiling software:

sudo apt-get install git build-essential

Then you need to download the software:

git clone https://github.com/lwfinger/rtl8723au.git

After that, compile the software and install it:

make && sudo make install

All the commands together for convenience:

sudo apt-get install git build-essential && git clone https://github.com/lwfinger/rtl8723au.git && make && sudo make install

After a reboot, wireless will then work. The driver will have to be compiled and installed (make && sudo make install) every time the kernel is updated.

4
  • I did all the steps, no errors occured. Still the driver isn't working right. Just to make sure you didn't get me wrong: The wireless-chip did work! But the driver seemed to be buggy since signal-strength is jumping from full to 0 conitnuously. No problem if I'm next to the router, but a problem indeed if there's a distance between router and laptop! And even though no errors occured using your solution the signal-strength is still jumping. Really weird!
    – Finnhax
    Oct 13, 2013 at 20:11
  • Yeah, it sounds like there is a bug there... open a new issue at github.com/lwfinger/rtl8723au/issues and provide as much detailed information as possible. This includes dmesg, lshw -c network, and lsusb.
    – Richard
    Oct 14, 2013 at 1:33
  • Probably the problem is: I have a 8723AE, while this driver is for the 8723AU?
    – Finnhax
    Oct 15, 2013 at 18:02
  • The 8723AU driver seems to support the 8723AE chip as well.
    – Richard
    Oct 17, 2013 at 12:07
0

Have you tried:

sudo modprobe -rv rtl8723ae
sudo modprobe -v rtl8723ae swenc=1 ips=0 fwlps=0

Did not fix the problem in my case but might help in your case. Got it from here:

http://ubuntuforums.org/showthread.php?t=2177896&p=12805947#post12805947

Otherwise you could try installing the latest proprietary driver (after patching it for the 3.8 kernel) as described here:

http://ubuntuforums.org/showthread.php?t=2169602&page=2&p=12770984#post12770984

That fixed the issue in my case.

2
  • No errors occured while modifying, building or installing the proprietary driver as described in the article. But when I try "sudo modprobe -v rtl8723e" it tells me: "ERROR: could not insert 'rtl8723e': Invalid argument"
    – Finnhax
    Nov 8, 2013 at 1:19
  • You may try to reboot after executing "make install" so that the new module is loaded correctly. If executing "lsmod | grep rtl8723e" gives you something back after the reboot then you've correctly installed the new driver. You'll have to repeat the compiling and installing after every kernel upgrade.
    – jerico
    Nov 8, 2013 at 11:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.