I am having difficulty auto-mounting my newly created LVG. I tried adding the following line to /etc/fstab:

/dev/vgBackup/lvBackup /home/stuart/volume_backup ext3 defaults 0 1

I also tried swapping the /dev/vgBackup/lvBackup with something similar to UUID=f7b9a5e3-4fa3-4bfd-b9af-bf126c296213 based on the id that came up when I manually mounted the drive from nautilus by clicking on the volume (it showed up in /media). Unfortunately, with both cases, I get a bootup message telling me that mounting fails and I have to press S to skip.

Manually mounting the drive from the CLI with:

sudo mount /dev/vgBackup/lvBackup /home/stuart/volume_backup 

works though.

Perhaps fstab is the wrong tool to use? Ideally the drive should be available to write to for the stuart user instead of root.

Additional Info

  • The drive currently uses the ext3 filesystem
  • 3.5TB in size.
  • consists of a 3TB and a 500G physical drives

The usual way to mount LVM volumes seems to be via the device mapper symlink at /dev/mapper/vgname-lvname, for example if I have the following volumes

$ sudo lvs
  LV     VG   Attr   LSize  Origin Snap%  Move Log Copy%  Convert
  root   t60p -wi-ao 89.92g                                      
  swap_1 t60p -wi-ao  3.00g  


$ grep '/dev' /etc/fstab
/dev/mapper/t60p-root /                 ext4    errors=remount-ro 0       1
/dev/mapper/t60p-swap_1 none            swap    sw                0       0

This example comes from a 12.04 Server install with whole-disk LVM selected at install time, so the fstab is the one created by the installer. If I understand your naming convention correctly, the equivalent for your backup volume would be

/dev/mapper/vgBackup-lvBackup /home/stuart/volume_backup ext3 defaults 0 1

You should also be able to use the UUID corresponding to the mapper link, which you can get from blkid e.g. the output of sudo blkid -c /dev/null

You may also need to run sudo update-initramfs -u in order to make the device mappings available during boot.

  • Thanks! That worked for me. When I ran sudo blkid -c /dev/null it clearly showed that it was actually set to ext4 but I swear that when I ran make2fs, I created an ext3 filesystem. Is it possible that I made ext4 partitions and an ext3 filesystem, a mistake that will bite me later? – Programster Oct 13 '13 at 19:10
  • @steeldriver It's not working 100% for me. Please refer to my question at askubuntu.com/questions/728174/…. Please help if you can? Thanks in advance. – Ashu Feb 7 '16 at 1:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.