I am using Ubuntu without Unity but with Compizan Nemo as file manager. Since the update to Nemo 2.0 it does not render the desktop correctly anymore. Instead of the background picture I see a black background and every window movement leaves a strange effect on the desktop: enter image description here

Is this is a bug? Where to post Nemo bugs. Does someone know a workaround?

EDIT: I have created a bug report here.

The problem is, that in Nemo 2.0 it's capability to render the desktop was removed. See here


4 Answers 4


Cinnamon is causing problems when running Nemo desktop under Unity. You have to completely remove both packages, add the Nemo only PPA from NoobsLab, the Backports and Cinnamon repositories install Cinnamon packages along with Nemo, finally reinstall and configure Nemo.

Here are the steps that I followed to get Nemo installed independently:

  • Completely remove Nemo and Cinnamon

    sudo apt-get --purge remove nemo cinnamon

  • Make sure all packages are removed by using Synaptic Package Manager (there is probably a way to use regex with the apt-get remove command but I am not comfortable enough to try that) Note: I did this because some packages were not automatically removed using apt-get, I searched for both Cinnamon and Nemo to manually select any packages installed for either package then used the completely remove option.

  • Purge all entries for Cinnamon and Nemo from the compiz settings database

    dconf reset -f /org/cinnamon/ dconf reset -f /org/nemo/

  • Add the NoobsLab PPA and install Nemo Version 5.0~raring~NoobsLab.com

    sudo add-apt-repository ppa:noobslab/nemo sudo apt-get update sudo apt-get install nemo nemo-fileroller

  • Add Nemo to the mime defaults

    xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

  • Nemo by default is set to handle the desktop but Nautilus overrides that so just disable Nautilus

    gsettings set org.gnome.desktop.background show-desktop-icons false

Voilà! Nemo is happily taking care of your desktop again!


If your desktop is black when you first login:

  • Open Startup Applications (dash->Startup Applications)
  • Click "Add"
    • Name: Nemo
    • Command: nemo -n
    • Comment: Start the Nemo Desktop Manager

Reboot and Nemo will start

  • 1
    The command: "sudo add-apt-repository ppa:noobslab/nemo" yields: "Cannot access PPA (launchpad.net/api/1.0/~noobslab/+archive/nemo) to get PPA information, please check your internet connection." Do you mean: "sudo add-apt-repository ppa:noobslab/mint" Commented Oct 25, 2013 at 4:36
  • Following your directions, after a restart, the desktop is not black, but blank (no desktop icons) (also, I've added the start-up entry, still the same). When I run nemo, a new window opens, and also the rendering problem of the desktop re-occurs. Should we install an older version of nemo (1.x)?
    – Chris
    Commented Nov 8, 2013 at 14:04
  • NoobsLabs simply copies the packages from the WebUpd8 Nemo PPA and re-brands them. So why not use the original? webupd8.org/2013/10/install-nemo-with-unity-patches-and.html I tend to fix a lot of Nemo stuff for that PPA and usually those fixes arrive weeks and sometimes months later in that other PPA. For instance, at the time I'm posting this comment, the WebUpd8 Nemo PPA has Nemo 2.2.1 (with quite a few extra fixes compared to upstream; I uploaded it to the PPA about 2-3 weeks ago) while the NoobLabs PPA has Nemo 2.2.0 - screenshot: i.imgur.com/6KdyRKH.png Commented May 19, 2014 at 11:43

Since I had originally installed nemo following the instructions listed here:


I reversed it using ppa-purge instead of manually hunting down all the packages:

sudo ppa-purge ppa:gwendal-lebihan-dev/cinnamon-stable

After that I followed Andy Braham's instructions to used the NoobsLabs PPA for Nemo.


I had what I think was a closely related problem. I am running Gnome Shell in Quantal 12.10 and loaded Nemo to replace Nautilus. Unfortunately, I don't recall how I installed it.

After a while, my desktop failed to render properly. It looked strange; as-if the theme had been lost. The Look-and-Feel of Gnome Shell was gone. The colors made editing filenames on icons impossible. There were a number of other major annoyances.

I followed Andy Braham's advice (from the accepted answer) to remove the software. But then I followed the Noob Labs's blog posting http://www.noobslab.com/2013/10/nemo-file-manager-with-extensions-for.html to reinstall Nemo.

After a reboot, the problem was resolved. I hope it stays resolved. But I'm not sure, since I saw the problem come and go (mostly come and stay) prior to the fix.

[It really seems that Ubuntu is fragmenting into either a) an unacceptably de-featured desktop OS; or b) a difficult to configure desktop OS. Hopefully that will improve eventually.]


I had the same problem, but got it working now with nemo 2.2.1.

What I did was

  • purge cinnamon-daily completely as mentioned by user114408

    sudo ppa-purge ppa:gwendal-lebihan-dev/cinnamon-daily
  • follow all steps as mentioned by Andy Braham including the update, except I used http://ppa.launchpad.net/webupd8team/nemo/ubuntu instead of noobslab.

I don't have the glitch anymore. I will try install cinnamon again (stable version this time) and if the problem comes back I'll post it here. But since you aren't using cinnamon, the above should work. Worked for me in Ubuntu 14.04 anyway.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .