2

A week ago, I upgraded to Ubuntu 13.10 (with deja-dup 27.3.1-0ubuntu1). Since then, Deja Dup hasn't been able to complete any backups.

It goes through Preparing, and in the beginning, it managed to get to Reading. Then, it would list 101 files in the details window. After that, the progress bar keeps spinning back and forth, but there's no disk nor network activity. The system monitor reports deja-dup as running, but the sub-process duplicity is sleeping. All the files it lists are small, most of them 1kb-1000kb.

After an update(?) a few days ago, it can't even get past Preparing. Now, it doesen't start any subprocess, and it often freezes.

What I've tried: -Giving it a empty backup destination and setting it to ignore the last file it lists. No difference. -When running "deja-dup --backup" in a terminal, I get a empty(white) window and no terminal output. -After I start the backup, I am unable to open the backup settings or to retry the backup until I reboot the computer. The same happens if I start, then cancel/postpone the backup before opening settings or restarting the backup. -I have also tried removing ~/.cache/deja-dup folder, but it doesn't seem to make any difference.

Any idea how I can get it to work again? Or can anyone recommend a similar program?

1

You could try this from a terminal to see what's going on:

  1. Have a look at file /tmp/deja-dup.log after running the following line and replicating the problem (the file gets written after the deja-dup exits):

    DEJA_DUP_DEBUG=1 deja-dup --backup > /tmp/deja-dup.log

  • First, sorry about slow response, I've been very busy. I ran the command today, and the file gets created, but nothing is written to it. Any ideas? – Simen Oct 29 '13 at 16:53
  • Are you sure that you're looking at the log-file after Deja-dup has done its job and exited? If you look at the file while the program is still running it'll be an empty file. The file gets written only after deja-dup exits. – user824924 Nov 3 '13 at 23:15
  • Yes, but deja-dup freezes when I try to close it, could that keep the file from being written? – Simen Nov 5 '13 at 21:19
  • Found a workaround: by using FTP instead of WebDAV, the backup completes successfully. But thank you very much for taking your time to help me anyway :) – Simen Nov 5 '13 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.