12

I'm running both Ubuntu (10.04) and WinXp on the same machine, thus using the same keyboard. On Windows I have selected "United States (International)" as my keyboard setting.

In Ubuntu I have "USA International (AltGr Dead Keys)". However, they work slightly different.

When I press the " -key (or the '-key) in Windows, the resulting character depends on the next typed character. For example I can get foreign characters like é and ë.

When I press the " -key in Ubuntu, it just displays a " character, thus not allowing me to get special characters.

I prefer the Windows version, but don't know how to get this done in Ubuntu.

Here's a few screenshots to show you in case I failed to explain: Windows:

Windows

Ubuntu (same key sequence):

Ubuntu

4

You have to combine the dead key with the right alt key. For example, to get é, type RightAlt+' then E.

I've encountered the other option in the past (possibly back in the days when I used XP) and been annoyed by it. In my view, Ubuntu's approach is superior. After all, typing ' is more common than typing é; thus, it should be easier to type.

  • thanks, tbh I didn know what was meant by dead keys. I changed it from 'altgr dead keys' to 'with dead keys' and now has the desired effect. wóót ;). Also whether or not it's superior, depends on what language you speak. I have a US laptop but I write in dutch, french, Icelandic, ... all of which ocassionally use accents and even though type ['] is more common, going to character map everytime you are typing a text is a LOT more cumbersome. Thanks so much!!! – joon Apr 18 '11 at 15:40
  • 1
    Why would you need to go to character map with AltGr dead keys? – JanC Apr 18 '11 at 16:20
10

If you still want the dead key behaviour (typing ' and e resulting in é), you can use the English (US, international with dead keys) layout.

  • Excellent, thanks! This works great. In Xubuntu 16.04 I was even able to add the "Keyboard Layout" widget item to the panel in order to easily switch between my two keyboard layouts now: English (US), and English (US, International with dead keys), but one character still eludes me: how do I type the french c-cedilla with this international keyboard layout? – Gabriel Staples Sep 16 '16 at 1:29
  • Weird, it's right alt + comma (,), to get ç. See here: askubuntu.com/a/363598/327339 – Gabriel Staples Sep 16 '16 at 1:37
  • if you ever want to know how to type a certain character, you can always consult the keyboard layout chart (via either the text entry panel item in the menu bar or via system settings > text entry, the small keyboard icon in the bottom right of the list) The keys are shown with possible modifiers, clockwise, starting top-left: Shift, Alt Gr+Shift, Alt Gr, none. – webmaster777 Jul 6 '17 at 6:33
7

Use the English (US, Alternative international) layout.

  • This worked for me on Kubuntu 16.10. – Stephan Vierkant Mar 28 '17 at 21:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.