First, im new in ubuntu so please bear with me.

My firefox used to be working normally for the first time i installed ubuntu 13.04. I dont feel did anything wrong, but it suddenly cant be opened via the launcher. When i tried to type "firefox" in the terminal, it shows the very same error like this question.

So, i followed the answer in that question, and voila...its working now :D

However, something is still bothering me. Why is this happened suddenly? The fact that i used chown to make it works again means that the owner of the firefox is changed.

And why this message is still appearing in the terminal although the firefox is working now : GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

Thanks for your time :D


That message always appears in the terminal when you open firefox, it's not a problem. I can't quite explain it, but it's a bit like when scammers trying to sell you so-called 'antivirus' in Windows they show you a program which contains a load of normal errors and say that it's not normal. Just forget about it. You probably opened it with root as sudo instead of gksudo some time by accident which would cause stuff to have different permissions.

  • Glad to hear it, Thanks :D So, its always safer to use gksudo when running GUI based program, is it true? – Blaze Tama Oct 13 '13 at 8:46
  • and the point is, sudo and gksudo could change the permission automatically right? I should be careful next time :D – Blaze Tama Oct 13 '13 at 8:57
  • Yes, that's exactly it. (first comment) – user171354 Oct 13 '13 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.