0

When launching gnuradio companion it gives this error message:

Cannot import gnuradio.

Is the python path environment variable set correctly?
    All OS: PYTHONPATH

Is the library path environment variable set correctly?
    Linux: LD_LIBRARY_PATH
    Windows: PATH
    MacOSX: DYLD_LIBRARY_PATH

I do have python 2.7.3 installed. I installed gnuradio using binaries .deb file from the website below:::: http://ettus-apps.sourcerepo.com/redmine/ettus/projects/uhd/wiki/GNURadio_Linux I do not think the problem from GNURadio something it should be done with those libraries...

  • How did you install gnuradio-companion? – Takkat Oct 13 '13 at 8:06
  • I used a binary package taken from website below:::: ettus-apps.sourcerepo.com/redmine/ettus/projects/uhd/wiki/… – kohahoha Oct 13 '13 at 11:30
  • The usual solution of running sudo ldconfig probably wouldn't do anything that hasn't already been done installing the .deb package, and investigating how the OP compiled it simply doesn't apply. (Both are described here.) I think a solution would need details like the version of gnuradio (which may have been apparent when this was posted but isn't anymore) and the output of echo "$PYTHONPATH", echo "$LD_LIBRARY_PATH", dpkg -L with the package name, and ldconfig -v, and that we can close this as unclear or OT no repro. – Eliah Kagan Aug 24 at 16:15
0

In what must be my 6th distinct attempt in as many months to setup and run GNU Radio on Windows, I have finally succeeded! I admit I'm a little delirious with joy and disbelief. I'm answering here because I was getting the exact same error you are, and I suspect you're having the same problem despite the different platform.

What worked for me (after installing GNU Radio binaries from Ettus, including adding it to the path, and installing Python 2.7):

  1. Set PYTHONPATH=[your Python install]\Lib\site-packages;[GNU Radio install]\lib\site-packages
  2. pip install pygtk
  3. pip install numpy
  4. pip install lxml
  5. pip install Cheetah

(Note: on Windows, pip installs must be run from elevated command prompt "Run as administrator")

I figured out the problem by launching Python interactively and trying the failing statement from gnuradio-companion.py manually, from gnuradio import gr which gave me ImportError: No module named numpy. That's when it clicked that the module loading was failing while loading its dependent modules, and pip to the rescue to solve that!

0

Try this after setting the PATH variables

ln -sf /usr/lib/x86_64-linux-gnu/libvolk.so.1.3.1 /usr/lib/x86_64-linux-gnu/libvolk.so.1.3

-1

I also have been plagued by this problem. I have a solution that works for me, but I am at a loss to explain why it works. I stumbled upon it entirely by accident.

At a shell prompt type:

CODE export PYTHONPATH=/usr/local/lib64/python2.5/site-packages CODE

Yes, even though I have Python 2.7 installed, and the diectory is, in fact, named "python2.7". Set the environment to look for "python2.5"

Giving the "env" command at the terminal shows that the "PYTHONPATH" is now set to look for "python2.5"

Now, gnuradio-companion starts up without the error dialog.

  • 1
    Bad idea, won't this break other apps that need 2.7? – Tim Dec 14 '14 at 20:32
  • @Tim: You are correct, it might break other things that depend on Python2.7. I have not tested if this is so.The larger question to be asked is this: what if anything is broken in gnuradio-companion that something like my proposed solution should work? It should NOT work, but it does. I wish I had the time to look into this more. Meanwhile, making the change at the shell prompt ensures that you can test this, look at gnuradio-companion, reboot, and be back to normal. – M. G. Christensen Dec 18 '14 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.