Yesterday I installed cinnamon and nemo but didn't like it (don't ask me why).

I am using unity now and I has no reason to remove cinnamon but now when I launch nautilus from terminal, I get this error:

Initializing nautilus-dropbox 1.4.0

Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare'
returned error 255: info_fn: file /var/lib/samba/usershares/files is not a
well formed usershare file.

info_fn: Error was Path is not a directory.

This is the first time I am seeing this error, and I think removing cinnamon & nemo will solve the problem (But I want to remove it anyway).

So, sudo apt-get autoremove cinnamon nemo shows that only ~7MB space will be freed, while ~70MB was downloaded. Where's the rest of space? And how do I solve that nautilus problem?

  • Yes you have to remove using autoremove once removed you have to execute this command to completely remove it with configuration files : sudo apt-get --purge remove cinnamon. Sometime you need to execute same command two-three times to completely remove the packages.. Try it it will remove cinnamon completely.. Reply.. Oct 12 '13 at 15:27
  • --purge remove cinnamon after autoremove nemo cinnamon didn't do anything. But running autoremove nemo cinnamon again removed additional 23MB. But the nautilus problem is still not solved. It says some problem with nautilus-dropbox but dropbox share is working fine :/
    – Sourabh
    Oct 12 '13 at 15:35
  • I told you na! sometimes you have to execute same commands two three times.. It happened with me many times.. Good to know you solved your problem.. Oct 12 '13 at 15:40
  • A quick restart solved the nautilus problem too. But I am still left with gnome which was installed with cinnamon (I think :P). Any way to remove that too?
    – Sourabh
    Oct 12 '13 at 15:41
  • 1
    Were you trying to remove cinnamon while using cinnamon? You have to logout and login with Unity-shell and completely remove all the configuration files of cinnamon. To do so execute this command : find . | grep cinnamon | xargs rm -r -f. Then restart your system once.. Oct 12 '13 at 15:46

Cinnamon and Nemo has several dependencies that other packages that you might have installed use:

apt-cache depends cinnamon nemo
  Depends: gir1.2-clutter-1.0
  Depends: gir1.2-glib-2.0
  Depends: gir1.2-gmenu-3.0
  Depends: gir1.2-gtk-3.0
  Depends: gir1.2-muffin-3.0
  Depends: gir1.2-networkmanager-1.0
  Depends: gir1.2-soup-2.4
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo2
  Depends: libcanberra0
  Depends: libclutter-1.0-0
  Depends: libcogl-pango12
  Depends: libcogl12
  Depends: libcroco3
  Depends: libdbus-glib-1-2
  Depends: libgdk-pixbuf2.0-0
  Depends: libgirepository-1.0-1
  Depends: <libgjs0-libmozjs185-1.0>
  Depends: libgjs0c
 |Depends: libgl1-mesa-glx
  Depends: <libgl1>
  Depends: libglib2.0-0
  Depends: libgnome-desktop-3-4
  Depends: libgnome-keyring0
  Depends: libgnome-menu-3-0
  Depends: libgstreamer0.10-0
  Depends: libgtk-3-0
  Depends: libjson-glib-1.0-0
  Depends: libmozjs185-1.0
  Depends: libmuffin0
  Depends: libnm-glib4
  Depends: libnm-util2
  Depends: libpango1.0-0
  Depends: libpolkit-agent-1-0
  Depends: libpolkit-gobject-1-0
  Depends: libpulse-mainloop-glib0
  Depends: libpulse0
  Depends: libstartup-notification0
  Depends: libx11-6
  Depends: libxfixes3
  Depends: libxml2
 |Depends: dconf-gsettings-backend
  Depends: <gsettings-backend>
  Depends: gconf2
  Depends: python
  Depends: cinnamon-common
  Depends: gnome-session-bin
  Depends: gjs
  Depends: gnome-settings-daemon
  Depends: gsettings-desktop-schemas
  Depends: gnome-icon-theme-symbolic
  Depends: gkbd-capplet
  Depends: gir1.2-accountsservice-1.0
  Depends: gir1.2-gconf-2.0
  Depends: gir1.2-gkbd-3.0
  Depends: gir1.2-gnomebluetooth-1.0
  Depends: gir1.2-gnomedesktop-3.0
  Depends: gir1.2-cogl-1.0
  Depends: gir1.2-gdkpixbuf-2.0
  Depends: gir1.2-pango-1.0
  Depends: gir1.2-polkit-1.0
  Depends: gir1.2-upowerglib-1.0
  Depends: gir1.2-caribou-1.0
  Depends: gir1.2-javascriptcoregtk-3.0
  Depends: gir1.2-webkit-3.0
  Depends: libjs-jquery
  Depends: python-gconf
  Depends: python-lxml
  Depends: python-dbus
  Depends: python-imaging
  Depends: python-pyinotify
  Depends: mesa-utils
  PreDepends: multiarch-support
  Recommends: gnome-control-center
  Breaks: gnome-control-center
  Breaks: gnome-control-center:i386
  Conflicts: cinnamon:i386
  Depends: desktop-file-utils
  Depends: gsettings-desktop-schemas
  Depends: gvfs
  Depends: libglib2.0-data
  Depends: nemo-data
  Depends: shared-mime-info
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo-gobject2
  Depends: libcairo2
  Depends: libexempi3
  Depends: libexif12
  Depends: libgail-3-0
  Depends: libgdk-pixbuf2.0-0
  Depends: libglib2.0-0
  Depends: libgnome-desktop-3-4
  Depends: libgtk-3-0
  Depends: libnemo-extension1
  Depends: libnotify4
  Depends: libpango1.0-0
  Depends: libx11-6
  Depends: libxml2
  Suggests: eog
 |Suggests: evince
  Suggests: <pdf-viewer>
 |Suggests: totem
  Suggests: <mp3-decoder>
  Suggests: xdg-user-dirs
  Recommends: eject
  Recommends: gvfs-backends
  Recommends: librsvg2-common
  Recommends: <nemo-fileroller>
  Conflicts: nemo:i386

So to remove them you must remove them one by one checking that no other packages has explicit dependency of them. Non explicit dependencies are Recomends and Suggests.

About the error it might be that you (or Cinnamon/Nemo) have shared a directory that it couldn't share and now you are seeing this "error". The solution is find what directory is this renaming it or just drop the sharing as stated here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.