3

I've created /usr/share/X11/xorg.conf.d/51-synaptics-userdefined.conf file (copy of 50-synaptics.conf, only desired stuff changed and posted) with the following contents:

Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "HorizEdgeScroll" "true"
    Option "HorizScrollDelta" "106"
    Option "RTCornerButton" "0"
    Option "SHMConfig" "on"
    MatchDevicePath "/dev/input/event*"
EndSection

However, the settings aren't applied and every time Ubuntu starts I have to apply the settings manually. What am I doing wrong?

3
2

##Ubuntu 16.04 (Xenial) solution:

Hmm :-/ I'm afraid this didn't work for me with ubuntu 16.04 Dell XPS13. Instead I discovered, Touchegg

https://samtinkers.wordpress.com/2016/06/13/3-finger-gestures-in-ubuntu-16-04/

sudo apt install touchegg

To enable 3 finger and above touch in Ubuntu 16.04 (of course be sure your touchpad driver supports multitouch, or else upgrade your kernel)

Go to your home directory and create an .xprofile with the following content:

then

synclient ClickFinger3=0
synclient TapButton3=0
touchegg &

Now after you reboot your laptop, you’ll be able to use gestures.

1
  • Finally a good -- and easy -- 16.04 solution. I added this as a header to stress the momentary relevance.
    – loki
    Mar 15 '17 at 9:26
0

A comment in the file reads:

# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
0

In the meantime I discovered a utility called synaptiks. (I'm using KDE now)

It solved the problems I had.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.