15

When my computer is locked, I am presented with the default Ubuntu lockscreen. When I enter my password and unlock it, I am presented with the Cinnamon 2 lock screen and I have to enter my password again.

How can I disable the Cinnamon 2 lock screen?

Note: I've installed Cinnamon 2 with these commands:

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
sudo apt-get update
sudo apt-get install cinnamon

6 Answers 6

21

After a bit of searching in dconf-editor (inspired by the other answers and not gconf), I found the schema

org → cinnamon → desktop → lockdown

which contains a key called disable-lock-screen, set that to true (checked) to disable the Cinnamon lock screen.

dconf-editor screenshot here


Command Line

To turn lock screen off:

gsettings set org.cinnamon.desktop.lockdown disable-lock-screen true

To turn back on:

gsettings set org.cinnamon.desktop.lockdown disable-lock-screen false
3
  • Think those settings should be in single quotes. +1 for edit.
    – user128334
    Dec 12, 2013 at 4:10
  • oh man this killed me until I found it. Actually saw this setting but didn't grok the inverse 'set this to disable the feature'.
    – ether_joe
    Jul 5, 2015 at 3:14
  • I found it in, org → mate → desktop → lockdown
    – Gunith D
    Feb 13, 2017 at 5:40
3

After installing Cinnamon the way you did, and running it, opening gconf-editor, I coudn't find a cinnamon entry under desktop, only gnome. You can disable the Gnome lock screen, and see if that helps.

enter image description here

1
  • It's org/gnome/desktop/lockdown now. Anyway, you can use the search button to look for lockdown if it's unlisted, and pick the most sensible one for the gnome screen.
    – Herbert
    Jan 28, 2020 at 9:31
3

Uninstalling gnome-screensaver fixed the double lock issue for me.

If you prefer the gnome-screensaver, as OP does, simply remove cinnamon-screensaver instead.

1
  • Thank you... It's truly unbelievable that we actually have to go through a check list of procedures to stop, get rid of this unwanted / annoying screensaver.
    – NpC0mpl3t3
    Jul 17, 2020 at 4:39
1

you have to install gconf editor for that. after install gconf editor , open it navigate as desktop - cinnamon - lockscreen or desktop - gnome - lockscreen . there you can disabled the cinnamon lock screen.

I think cinnamon using gnome lock screen.

try it.

-2

I installed xscreensaver on my system but cinnamon-screensaver still butts in and takes over.

An easy solution is this:

sudo mv /usr/bin/cinnamon-screensaver /usr/bin/cinnamon-screensaver.bak

then:

sudo vi /usr/bin/screensaver

and add the following lines:

#! /bin/bash

exit 0
1
  • 1
    although this may solve the question, I moving/renaming binaries isn't a good solution as it bypasses the dpkg package system, which can lead to all sorts of problems. The least of which will be that on an update the old binary may be restored, leading to a re-occurrence of the problem.
    – ph0t0nix
    Nov 11, 2014 at 22:10
-3

Or do this:

sudo chmod -wx /usr/bin/cinnamon-screensaver

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.