6

I want to assign a shortcut key for the Hibernate functionality. I have Fn + F11 for hibernation in Windows, but it's not working on Ubuntu. It's getting in sleep mode instead.

I've also tired changing the keyboard shortcut option as Ctrl + H with command pm-hibernate, but still it didn't work. I referred this Ubuntu Forums Thread but couldn't find any solution for this.

Any solution please?

1
  • Thank you every one for there comments. Finally I found something strange. I assigned the ctrl + H with command pm-hibernate. Now my computer goes into Hibernate as follows: Step 1> ctrl+alt+T Step 2> ctrl + H H H.... yes tap H three time it works ..strange but works..I dont know why ..
    – MrA
    Commented Oct 23, 2013 at 23:11

2 Answers 2

1

If you need to setup hibernation shortcut sequence, you go to Ubuntu System settings (Ctrl+Alt+T and then typing gnome-control-center) and then choosing keyboard settings.

Settings

Under that, you will see a tab that says "shortcuts", and there will be an option to set a custom command :

set custom command

Then you will need to put the command you want to hibernate your computer.

1
  • 1
    I guess, you don't want to enter your password every time you hit those keys. Here's a command that does without one: dbus-send --system --type=method_call --dest=org.freedesktop.UPower /org/freedesktop/UPower org.freedesktop.UPower.Hibernate Commented Oct 13, 2013 at 12:55
0

Firstly, Hibernate will need to be enabled. Go into console and type

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla

In the new gedit window, copy-paste this in:

[Re-enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Save and close the file, reboot the computer, and then you have it available as a menu option. Assuming you're on a laptop, the fn + F11 shortcut should work afterwards as well, if this is a default option that came with the laptop (i.e. printed on the keyboard, etc.).

3
  • Thanks for the answer. I already have hibernate setup as menu, as you did in your steps.I am able to select Hibernate from drop down menu. But I am unable to assign any shortcut key for Hibernate. Is there any way that I can assign shortcut key to hibernate. Any customization?.
    – MrA
    Commented Oct 12, 2013 at 3:01
  • Did you try using fn + F11 after enabling Hibernate? Commented Oct 12, 2013 at 13:00
  • Yes it goes in suspend mode...
    – MrA
    Commented Oct 12, 2013 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .