32

First, I've tried searching several threads to find the answer, but I couldn't find one that solved my problem, so I'm opening a new one here.

I just installed Ubuntu 11.04 with the new Unity desktop, and I'm trying to change the key binding of Super+t from Open Trash (which I don't have much use for) to Open Terminal (which I use all the time). I tried running "Keyboard shortcuts" and changing the binding in there to "Mod t," but that didn't work and it seems to get overridden by something else.

So then I installed compiz-config-settings-manager and I looked for a keybinding in there for Super+t, but I couldn't find any. In fact, I even tried changing a random feature in ccsm to Super+t hoping that it would tell me there was a conflict with that binding and I could locate it there. But instead it let me use Super+t. Sadly, after I changed it, I pressed Super+t and it still opened the trash.

Is there another place that I can change the key bindings of Super+t?

3
  • 3
    It might not help, but by default in Unity you can open the Terminal by pressing Ctrl+Alt+T. Apr 23, 2011 at 21:08
  • 2
    Yes, a real answer is necessary here. Why does the tool designed for keybinding manipulation get overridden by unity defaults?
    – user21105
    Jul 4, 2011 at 20:54
  • 3
    It seems that the issue is that it's hard-coded into unity. Big failure, I think
    – emf
    May 12, 2012 at 2:13

4 Answers 4

18

In the Compiz Config open the Unity Plugin page, change the "Key to show the launcher" to anything other than just Super. Mine is Alt+Super.

This will alter all Unity shortcuts. So opening the first program in your launcher is no longer Super+1 but Alt+Super+1.

They should really have a configuration panel for Unity shortcuts.

4
  • 1
    @aldomann, thanks for the comment. I prefer Super+t over Ctrl+Alt+t, but it's working for now
    – Lemurman
    Apr 30, 2011 at 5:05
  • thanks for the response. I agree, they should have a configuration panel. Til then, I'll have to evaluate giving up other features of Unity's using only the Super key for my terminal shortcut.
    – Lemurman
    Apr 30, 2011 at 5:06
  • @Eufouria, I also changed the Unity launcher key to Alt+Super but Alt+Super+1 does not launch the first program as expected. It only works when the launcher key is set to Super. Does it work for you? I suspect it's a bug. I'm using Ubuntu 11.10 x64.
    – user48443
    Feb 28, 2012 at 16:56
  • I had to change settings on Unity Plugin page several times before they took place. The settings kept resetting without no apparent reason. I also sensed different behaviour when using Unity or Unity 2D. Jan 22, 2013 at 14:35
4

This isn't a real answer to the question but another approach in unity manner.

If you use it often consider putting it into the unity launcher. Just search for "terminal" and then drag the icon to the left side pane. You can then start it with Super-[number].

Just in case you're interested: I want to know the real answer too!

2
  • 1
    I thought this was useful, because it was a common-sense answer to the question, given that the actual answer is "unsolvable issue".
    – emf
    May 12, 2012 at 2:12
  • I do this too. Lets me open terminal quickly with just my left hand. I assume that is what you were going for.
    – Jodamo117
    Mar 10, 2017 at 0:11
3

My muscle memory is also programmed to use Super+t for open terminal, so I decided to make a ppa for this: https://launchpad.net/~hansvschoot/+archive/ubuntu/unity7. It contains the unity 7.2 branch at the moment (which is used in 14.04) with line 56 of the launcher/TrashLauncherIcon.cpp commented out to remove the shortcut.

So if you are running ubuntu 14.04 you can run the following commands to add the ppa and install the modified unity:

sudo apt-add-repository ppa:hansvschoot/unity7
sudo apt-get update
sudo apt-get install unity

afterwards you can simply use the shortcuts tab under keyboard settings to assign Super+t to open a terminal

2
  • Sorry, but I've installed your plugin but it doesn't seem to work. Have you got any idea why? Jun 13, 2015 at 11:58
  • 1
    This is a pretty bad idea. Making a custom PPA for Unity will likely end up with many people having outdated versions of unity running on their system.
    – Lotus
    Jun 17, 2015 at 12:19
-1

The default shortcut for opening a terminal is Ctrl+Alt+T, so you don't necessarily need to change it, just start using the default.

But if you do want to customize shortcuts, the keyboard settings panel in Ubuntu 13.10 (I will confirm 14.04 soon), is where the "Launch terminal" shortcut is controlled.

I changed it to Super+T and it now works to open a terminal instead of the trash.

3
  • Nah, I doesn't work in 14.04. Jun 15, 2015 at 18:01
  • 2
    Also confirmed it no longer works in 15.04.
    – mp3foley
    Jun 16, 2015 at 23:44
  • not work in 16.04 either
    – Hiep
    Feb 27, 2017 at 2:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.