1

I'm running Ubuntu 12.04 on an Acer C7 chromebook with chrubuntu. Overall, it works very well, but there is one minor problem. I would like one finger for left click, and two for right click.

I can achieve this easily with the following commands

synclient TapButton1=1
synclient TapButton2=3
synclient TapButton3=2

However, after reboot (or closing/opening the lid), when I query synclient, the settings are as follows:

TapButton1 = 3
TapButton2 = 1
TapButton3 = 0

This is an odd and undesirable three-finger left click! This persists, even though I have added the following lines to /usr/share/X11/xorg.conf.d/10-synaptics.conf

Option "TapButton1" "1"
Option "TapButton2" "3"
Option "TapButton3" "2"

I've tried adding the synclient commands to correctly configure the touchpad to /etc/rc.local, but it still starts up incorrectly. The only workaround is a script that sets up the touchpad correctly, which I run everytime I re-open the lid. It works, but not the most elegant fix for an otherwise excellent system

Any idea how I can make the touchpad configured correctly at startup, or re-opening the lid? Thanks

1

Re-installing following two packages could solve your issue:

xserver-xorg-input-multitouch
xserver-xorg-input-synaptics

Follow these steps to remove completely and install it again.

  • Open terminal and execute following command:

    sudo apt-get --purge remove xserver-xorg-input-multitouch
    

    be sure you don't remove any other package than xserver-xorg-input-multitouch

    sudo apt-get --purge remove xserver-xorg-input-synaptics
    

    again follow the same precaution.

  • Once removed execute these commands to install it again:

    sudo apt-get install xserver-xorg-input-multitouch
    sudo apt-get install xserver-xorg-input-synaptics
    

    again be sure you don't remove any other packages while installing it.

  • Once installed execute following commands to reconfigure it:

    sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}' | grep "^xserver" | tr '\n' ' ')
    sudo update-initramfs -u
    
  • Then restart your system. Reply if you need further assistance..

Edit

If above method doesn't help then you can give a try to gpointing-device-settings Install gpointing-device-settings.

  • You can install it by command:

    sudo apt-get install gsynaptics
    
  • When installed open it by searching gsynaptics or pointing devices in dash. You can also open it by browsing the path /usr/share/applications through any file manager. Hope its configuration helps you.

  • Thanks for helping, I tried this, but there doesn't seem to be any change. When I start up, I've still got the odd mouse configuration. Any other ideas would be most welcome. – Robin Oct 11 '13 at 18:42
  • Sorry! I forgot to mention a link. Have you tried this link – Saurav Kumar Oct 11 '13 at 20:36
  • Also try to install gsynaptics! Check my edit. – Saurav Kumar Oct 11 '13 at 21:23
0

Ok, fixed it. The mouse was set up as "left handed" under mouse settings, not sure why. This should be a bug as the left/right handed mouse settings should not affect touchpad tapping.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.