17

Not that I have anything against my trans-atlantic cousins, but I want to change my keyboard layout from US English to UK English.

I need to type ' # ' and ' ~ ' and I don't know what position they are at in Ubuntu!

# results in a \

#+shift results in a |

I want to solve the problem using the GUI.

  • 1
    Solved this question while waiting for an answer. Decided to answer it myself to expand the knowledge base. Is this the right idea? – Starkers Oct 11 '13 at 14:23
13

Go to Keyboard layouts under system settings, and click on it. Once open remove English (US), and add the English (UK) that you want. Click on the Plus (+) sign to add, and the minus(-) sign to remove. See images below.

enter image description here

enter image description here

(It will be English UK with Extended Win Keys)

| improve this answer | |
  • sorry this answer is useless for me now, there is no Keyboard Layout just Keyboard and it doesn't give me the options you state. I don't see why it is so difficult for keys on a keyboard to simply print the character that is marked on it. – CashCow Jan 25 '15 at 12:22
  • 2
    It's called 'Text Entry' in Ubuntu 14. – Dan Atkinson Apr 29 '15 at 10:01
23

On ubuntu fresh install:

Login and press Ctrl-Alt-T to open a Terminal and run:

setxkbmap -layout gb  

To get UK keyboard with double-quotes on Shift-2 and @ sign on RHS.

| improve this answer | |
  • 2
    This works on LUbuntu. Far easier doing this than looking through the menus for system settings – cup Aug 31 '15 at 10:54
  • A useful answer for many, as evidenced by the number of upvotes, but note that the Original Poster asked to solve the problem through the UI. I'm not sure if opening a terminal and typing into it satisfies that requirement. It's still good to have this answer here for people who are comfortable typing in the terminal, as the UK layout isn't too different from the US layout. This solution would be less acceptable for changing to keyboard layouts that differ more from the US layout, as the very act of typing in the command would be very difficult. – Rob Davies Apr 10 '19 at 15:53
  • It is not necessary to use the layout option – birdman Jun 14 at 8:35
  • it's also not permanent and is overrideen on next boot from dpkg-reconfigure keyboard-configuration – RichieHH Oct 7 at 11:30
4

Aware that using the GUI is very beginner esque, but I need to be able to type before I can get to grips with Ubuntu!

Click on settings, keyboard, and then, in the bottom left, Layout Settings. On the left there is a panel that displays currently installed keyboard layouts. By default, only English (US) is available. Below the panel, click the + icon and select English (UK). This will add English (UK) to the panel. Use the ^ symbol to bump English (UK) above English (US). The panel is hierarchical, so now English (UK) takes the priority.

You can even select English (US) and use the - to delete the keyboard from the panel.

| improve this answer | |
  • Also useless. No such option as Layout Settings. Only a load of useless Windows type options. I'm not using Windows for a reason yet Ubuntu seems to want to bring in a lot that is s**t about that system like taking over your keyboard to do stuff you don't want because you hold down the shift for a few seconds by mistake and no Ctrl-Z undo. – CashCow Jan 25 '15 at 12:27
  • This worked for me. Its a menu now called "Test Entry" then click on the "+" and select English (UK) – Dean Meehan Nov 9 '15 at 15:39
2

Just run the following command in terminal:

gsettings set org.gnome.libgnomekbd.keyboard layouts "gb"

This will change your keyboard layout to English (UK).

| improve this answer | |
  • 9
    I get 0-2:unknown keyword typing that command. – artfulrobot Jan 7 '14 at 21:13
1

Run the following command.

setxkbmap -layout gb

This worked for me in Lubuntu 15.10.

| improve this answer | |
  • works on 16.04 as well – Infamous Jul 4 '17 at 7:43
1

There are two ways to do it in Ubuntu (14.04)

  1. En1, icon at the top right of your screen change it with English (US) or English (UK), checkout keyboard layout chart in same line, to know which key may function. If English (UK) is not there, check out point 2 (reach text entry). Once there Enable Show input source in menu bar to (en) in menu bar.
  2. Go system System Settings -> (in hardware section) Keyboard -> find Text entry link -> on the input source list find the + sign and click to add language (whatever language you want). Once you have added the language you can follow point 1 above to change language back and forth.
| improve this answer | |
0

Open the search with super key. Find "Text entry", select English (US) and press - to delete it. You should be left with English (UK)

| improve this answer | |
0

On Ubuntu 18.04 I found it under Settings -> Language & Region.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.