1

I am trying to install Ubuntu 13.10 64-bit with UEFI enabled (since Windows came preinstalled) and I want to keep Windows. I created a partition, installed Ubuntu successfully and then I repaired grub2 with Boot-Repair. I get the black on gray dialog that displays the Windows and Ubuntu entries but when I select Ubuntu I get an error:

Windows Boot Manager  

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:   1. Insert your Windows installation disc and restart your computer.   2. Choose your language settings, and then click "Next."   3. Click "repair your computer." If you don't have this disc, contact your system administrator or computer manufacturer for assistance.   File: \EFI\Ubuntu\grubx64.efi   Status: 0xc0000007b   Info: The application or operating system couldn't be loaded because a required         file is missing or contains errors.

saying that the file is corrupt or doesn't exist. Is there any way to fix this? I tried it with and without secure boot enabled.

Edit: the notebook is a sony vaio s if it helps.

  • Try to reinstall GRUB from your Live Ubuntu – s3lph Oct 11 '13 at 12:34
2

UEFI is known to cause problems with Ubuntu. I have yet to find a case where a UEFI installation initially works. The best fix for this is boot-repair. Here's what you can do to fix your problem:

  1. Start up your Live CD
  2. Open Terminal by pressing Ctrl+Alt+T
  3. Run sudo apt-get update && sudo apt-get install boot-repair
  4. Run sudo boot-repair
  5. Choose the Recommended Repair
  6. Follow the instructions you are given, then reboot once finished
  7. Profit!
  • 1
    I already tried that, I said so in the original post. – Dani Oct 11 '13 at 14:03
0

No guarantees, but try preparing a USB flash drive with the USB flash drive version of my rEFInd boot manager. You should be able to boot to rEFInd, which should give options for both Windows and Linux -- probably at least two for Linux. Select a Linux option with the string vmlinuz in the description. If this boots Linux, install the Debian package version of rEFInd, which will replace GRUB as your boot manager. If rEFInd fails, post details, including any error messages you see.

Another point: I doubt if it's related to your problem, but a common issue with Windows 8/Linux dual-boot setups is the new Windows "fast startup" feature. This feature turns shutdown operations into suspend-to-disk operations, which has the undesirable effect of not properly unmounting filesystems. This in turn results in filesystem damage because the two OSes don't share the same view of the disk. Thus, it's imperative that you disable this feature, as described here (among other places).

0

Try 32 bit version of EFI.

The windows you are using is 32 bit, so mbr is writed in 32 bit manner. You must use 32bit version of loader which will load you 64bit host OS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.