This question already has an answer here:

I know this question has been asked a million times before but I have checked out the previous posts and none of the advice given in them has worked for me. I'm getting this with the medibuntu repository.

  1. I'm running Xubuntu 12.04 so I know it's not an EOL issue.
  2. My internet connection is fine. I'm using it at the same time I'm doing the update. I'm able to surf the net, etc.
  3. I have a proxy but if that was the issue wouldn't all the repositories and PPAs be affected? Also, I've never had issues with the proxy server doing this before. This is the first time I have run across this error.
  4. I changed servers twice to different servers. I tried to select the best server and I tried the main server
  5. I tried the following three commands all without error sudo apt-get autoclean, sudo apt-get clean, and sudo apt-get autoremove. Then I tried running the update again and it still came up with the 404 error
  6. I ran sudo apt-get update | grep NO_PUBKEY and it just came up with the same error message

I don't know what else to do at this point.

marked as duplicate by Anwar, Zanna, Rinzwind, edwinksl, TheWanderer Sep 25 '16 at 3:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


The 404 error means that the page no longer exists: http://en.wikipedia.org/wiki/HTTP_404

Indeed, Medibuntu is no longer maintained: http://www.medibuntu.org/repository.php You should remove that PPA.

To remove it, use this solution: How do I remove a PPA added via command-line?


I just happened to have done a search for medibuntu and two sites have stated that medibuntu project has come to an end/been shut down.

From Ubuntu documentation

Medibuntu has now been shut down, the packagers were either obsolete, unnecessary or moved to the official Ubuntu archive.

Not the answer you're looking for? Browse other questions tagged or ask your own question.