I left my computer on overnight and when I came to it this morning it offered to update (I'm on Ubuntu 12.04). So I updated and restarted, now when I want to login, I get the message:

Could not update ICE authority file /home/user/.ICEauthority

I'm getting this on all accounts. I can't see a way to get into the terminal to sort this out, as various threads I've found suggest. If I use Ctrl+Alt+T nothing happens. If I use Ctrl+F1then just go to a black screen.

I tried using an old live CD (Ubuntu 8.04) but couldn't get to terminal via that either.

I made usb stick to boot 12.04 from but I have no option to boot from usb on the computer (it has USB sockets, but it's an old desktop).It's only got CdROM/HDD/Network boot as options.

I can't burn a boot CD of 12.04 because the file is too big.

Can someone suggest a way to get to the terminal so I can fix this?


How to fix .ICEauthority

Lifted from this post.

First you need to boot into recovery mode. If Ubuntu is the only system installed on your computer you need to hold Shift-Key while booting.

The recovery-mode entry on a single OS system

Select the "recovery mode"-entry which is usually the second one.

The menu from the recovery mode

  • Select "root Drop to root shell prompt".
  • Enter mount -o rw,remount / to make your system writeable


Go to your home folder. Change USERNAME with you actual username:

cd /home/USERNAME

Check if .ICEAuthority is owned by you

ls -al .ICEauthority

If it isn't (like it is owned by root) change it to you. As above change USERNAME with you actual username:

sudo chown USERNAME:USERNAME .ICEauthority

If you there is no such file you need to recreate it. Change USERNAME yada yada ... :

touch .ICEauthority
sudo chown USERNAME:USERNAME .ICEauthority
sudo chmod 600 .ICEauthority



to reboot your system.

Probale cause

You probably ran a graphical application with sudo as explained here.

  • thanks for the answer - using shift did not work it made me realise that i had an additional problem, my monitor was not showing terminal. so i sorted out another screen but this solution has not helped. i followed the instructions but still got the error message. so i deleted ICeauthority, still got the error message. so i tried to change the permissions again but now it says no such file. i'm a bit stumped. – martin Oct 11 '13 at 9:40
  • there are a range of solutions online which i am working through but none seem to work – martin Oct 11 '13 at 9:41
  • the probable cause in this case isn't running a graphical application with sudo, i wouldn't know how to do that. it stems i think from this update which is curious. – martin Oct 11 '13 at 9:41
  • some helpful links for other people searching for an answer to this exceedingly annoying problem:askubuntu.com/questions/55568/… askubuntu.com/questions/10543/… askubuntu.com/questions/39785/… – martin Oct 11 '13 at 9:42
  1. CTRL-ALT-F1 to get to terminal window
  2. sudo chmod 777 /home/xxx -R
  3. Switch back to the login screen by pressing Ctrl+Alt+F7 or F8

Not the answer you're looking for? Browse other questions tagged or ask your own question.