1

I want to install the newest version of PCmanFM on my Ubuntu 13.04 machine. I have download the the newest version from here. Now how do i actually install it and make it so that it is the system wide default? There is another thread maybe that can be updated for Ubuntu 13.04 and PCmanFm 1.1

1

You can try to download the source code for pcmanfm v1.1.2 and libfm v1.1.2 (For Ubuntu 13.10 Saucy Salamander) from Launchpad.
Compile, create the deb packages and install them in Ubuntu 13.04.

NOTE: I would recommend you to test this in a Virtual Machine first, to see if everything is ok.


1) Make sure you have enable the "Source code repository"

  • Open the Ubuntu Software Center
  • In the Menu Bar choose Edit -> Software Sources. Click to enable "Source code repository". Just in case I use the "Main Server" to Download.

enter image description here

And make sure you have also the universe repository enable.

Open a Terminal and type:

  • sudo apt-get update

2) In the Terminal window type the following to install the necessary packages.

  • sudo apt-get install build-essential wget pcmanfm

3) Install build dependencies.

  • sudo apt-get build-dep pcmanfm libfm

4) Create folders to download the source code to compile & install libfm.

  • mkdir ~/Downloads/src

  • cd ~/Downloads/src/ && mkdir pcmanfm libfm && cd libfm

cat > source-list <<EOF
https://launchpad.net/ubuntu/+archive/primary/+files/libfm_1.1.2-0ubuntu1.dsc
https://launchpad.net/ubuntu/+archive/primary/+files/libfm_1.1.2-0ubuntu1.debian.tar.xz
https://launchpad.net/ubuntu/+archive/primary/+files/libfm_1.1.2.orig.tar.gz
EOF
  • wget -i source-list && dpkg-source -x libfm_1.1.2-0ubuntu1.dsc && cd libfm-1.1.2
  • fakeroot dpkg-buildpackage && cd .. && sudo dpkg -i *.deb

5) Download the source code to compile & install pcmanfm.

  • cd ../pcmanfm/
cat > source-list <<EOF
https://launchpad.net/ubuntu/+archive/primary/+files/pcmanfm_1.1.2-0ubuntu1.dsc
https://launchpad.net/ubuntu/+archive/primary/+files/pcmanfm_1.1.2-0ubuntu1.debian.tar.xz
https://launchpad.net/ubuntu/+archive/primary/+files/pcmanfm_1.1.2.orig.tar.gz
EOF
  • wget -i source-list && dpkg-source -x pcmanfm_1.1.2-0ubuntu1.dsc && cd pcmanfm-1.1.2
  • fakeroot dpkg-buildpackage && cd .. && sudo dpkg -i *.deb

6) Make PcManFM default File & Desktop Manager.

  • xdg-mime default pcmanfm.desktop inode/directory

  • sudo mv /etc/xdg/autostart/nautilus-autostart.desktop /etc/xdg/autostart/nautilus-autostart.desktop.bak

  • sudo nano /etc/xdg/autostart/pcmanfm-autostart.desktop

The content of the pcmanfm-autostart.desktop file is:

[Desktop Entry]
Type=Application
Name=File Manager PCManFM
Exec=pcmanfm --desktop
OnlyShowIn=GNOME;Unity;
NoDisplay=true
  • Save the changes in nano with Ctrl+O, Enter then Ctrl+X.

7) Replace Nautilus icon for PCManFM in Unity Launcher.

  • favorites=$(gsettings get com.canonical.Unity.Launcher favorites | sed 's/nautilus.desktop/pcmanfm.desktop/')
  • gsettings set com.canonical.Unity.Launcher favorites "$favorites"

8) Restart Your Machine.

9) Finally open the PCManFM desktop preferences for customization (background,font etc).

  • pcmanfm --desktop-pref

enter image description here


RESULT:

enter image description here

enter image description here

Hope this helps.

| improve this answer | |
  • for step 2) I get 'E: Unable to locate package pcmanfm' – user194862 Oct 11 '13 at 19:13
  • Okay I trying this new version now. – user194862 Oct 11 '13 at 19:32
  • it works. pcmanfm but my desktop background is black and there are no icon except one for 'files' – user194862 Oct 11 '13 at 20:43
  • the black background, you have to change it with the desktop preferences step 9.. about the icons.. step 7 read your settings with gseetings and change only the nautilus.desktop with pcmanfm.desktop and store in the variable $favorites, the set again in gseetings with all the icons you had it but the only diference is change the nautilus for pcmanfm. – Roman Raguet Oct 11 '13 at 20:47
  • for some reason if i go to settings and then go to background and change the wallpaper. it does not change – user194862 Oct 11 '13 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy