I am unable to connect to the wireless network from Ubuntu 12.04 where as I can connect to the same wireless network via Windows 7, here is a snapshot of connected network in Windows 7 the SSID to which I have to connect to is bsnl2

connected in Windows 7

where as when I boot to Ubuntu I can not connect to the wifi network you can see following snapshot the router does not even shows SSID bsnl2 (to which I have to connect) how ever Ubuntu detects other SSIDs in my neighbourhood

SSID of bsnl2 is missing

Note in the Snapshot of Ubuntu the SSID bsnl2 is missing.

Following are the snapshots from my routers admin control panel page 1 of router page 2 or router page 3 or router page 4 of router page 5 or router page 6 or router page 7 of router page 8 or router page 9 or router

I do not see the SSID bsnl2 in Ubuntu 12.04 to which I have to connect.What is wrong here in Ubuntu? What more output should I post? If you notice the first snapshot in Windows 7 I see bsnl2 SSD with full signal strength and the computer is able to connect to it.So signal strength is also full (I am sitting next to router), some thing needs to be covered in Ubuntu , there is another SSID "aashish suraj" which is of my neighbour and I do not have to connect to it, the fact that Ubuntu is able to see other SSIDs in my neighbour just shows that Ubuntu wifi adaptors are also working correctly. Is ADSL router blocking Ubuntu traffic,(I have uploaded all snapshots) The router is Iball ADSL2+ 150M wireless router


Try this magic trick: Change your wireless channel to a number different from 13. Disable the automatic channel.

There are regulations regarding the use of WLAN channels. Channels 12, 13 and 14 are not allowed in North America. For more information: http://en.wikipedia.org/wiki/List_of_WLAN_channels#Interference_Concerns

From your router configuration, I assume that you are not in North America, but some wifi cards (and drivers) by default enforce the North America regulations. Some cards allow you to change this setting, and some don't. You can try this solution and see if it works for you: How to use Wi-Fi channels above 11?

I have the same problem with an Asus EEEPC, but I cannot change the country with those instructions. Not sure if it's a driver or hardware issue in my case...

If you are unable to make that changes, you can always configure you router to assume North America regulations, and set the channel to "automatic".

  • thanks that is quite awesome this has worked and solved the problem , but let me know why is setting channel manually required, and what should be the correct channel number to set? – Registered User Oct 10 '13 at 11:59
  • I'm a magician, and that my friend.... is pure magic! I'm kidding, I will update my answer with an explanation. – Hugo Vieira Oct 10 '13 at 13:21
  • Ha ha ha Lolz!! – Registered User Oct 10 '13 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.