1

So I was trying to get Ubuntu to be able to change the screen brightness correctly, and in one of the forum posts, someone suggested to try to change the grub file with "nomodeset." After I did so, my Ubuntu boots up to a full purple screen and gets stuck there.

I pretty much need to be able to modify my grub file again and change it to what it originally was. How can I do that?

Help please?

EDIT:

I tried booting into recovery mode, but I can't get past the black screen with all the text written on it. I think I'm getting a udevd error related to my graphics card.

5
  • did you take the backup of grub file that you changed? or do you remember what changes you applied? – Saurav Kumar Oct 10 '13 at 5:03
  • Yea I changed the line GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset" on accident – dtgee Oct 10 '13 at 5:44
  • Check my answer. and one more thing to fix the brightness you have to replace the line with : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" not what you've mentioned.. ;) – Saurav Kumar Oct 10 '13 at 7:41
  • Have you tried the way MadMide suggested? It is going to be so difficult if you even not be able to login using safe mode. It was the last option from my opinion. Hope his method works for you.. Give it a try.. Reply.. – Saurav Kumar Oct 10 '13 at 15:54
  • Enjoy and keep playing with Ubuntu.. Don't forget to say thanks to MadMike ;) – Saurav Kumar Oct 10 '13 at 16:16
1

How to change boot options temporarily

  • Boot your system.
  • Hold Shift to show the Grub-Menu if Ubuntu is your only system.
  • Go to the menu entry you want to (temporarily) change and hit e.
  • Delete the "nomodeset" from the kernel options.
  • Hit Ctrl + x to continue booting.
0

Follow these steps

  • Open your system in Recovery Mode, 2nd option from the Grub Menu, when your system starts. You may have to hold Shift while booting if your system starts without Grub Menu.

  • When starts select grub from the listed menu. It will ask like: your system will open in read/write mode. Chose yes. After updating your grub it will exit and again will come to the listed options.

  • Again chose root from the list.

  • now run following command to open your /etc/default/grub file:

    nano /etc/default/grub
    

    go to the line by Down arrow key and make possible changes. Save it by Ctrl+X and y.

  • Now update grub by:

    sudo update-grub
    
  • Restart your system, you problem should be solved:

    reboot
    

Reply if something goes wrong..

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.