1

I downloaded modelsim install file which contained .sh file in it -setup.sh I did the following two things

  1. Right click->properties->permision->allow executing file as program ->double clicked the setup.sh -> RUN. Nothing happened. No error...nothing.

  2. In terminal

    • cd /to the path of the setup.sh
    • chmod -x setup.sh ...nothing happened no error nothing. The cursor passd on to the next line
    • ./setup.sh ...nothing happened.

I also tired sh setup.sh and bash setup.sh, still nothing happened.

Downloaded the whole file again still nothing happened

Contents of the setup.sh file are:

#!/bin/sh
export SCRIPT_PATH=`dirname "$0"`
export CMD_NAME="$SCRIPT_PATH/components/QuartusSetupWeb-13.0.1.232.run"
eval exec "\"$CMD_NAME\"" $@
10
  • What are the contents of your script?
    – Seth
    Commented Oct 9, 2013 at 20:54
  • [CODE]#!/bin/sh export SCRIPT_PATH=dirname "$0" export CMD_NAME="$SCRIPT_PATH/components/QuartusSetupWeb-13.0.1.232.run" eval exec "\"$CMD_NAME\"" $@[/CODE]
    – aniket
    Commented Oct 9, 2013 at 20:56
  • 1
    Can you edit that into your question with the proper formatting? It's hard to read and understand in a comment.
    – Seth
    Commented Oct 9, 2013 at 20:57
  • 5
    Your chmod is wrong. It should be chmod +x setup.sh
    – troylatroy
    Commented Oct 9, 2013 at 21:27
  • 2
    Normally if you run a command and get no output, just another prompt, it means the command ran and exited without printing output. So it sounds like the script did run, but didn't do anything visible. Perhaps the installer QuartusSetupWeb-13.0.1.232.run quit unexpectedly. Did you ever find a solution? If the script was not marked executable (-x takes executable permissions away) then you should have gotten an error message, not nothing. This appears to be abandoned and, although some people have tried, I don't think it can really be answered based on the information available. Commented Sep 22, 2017 at 2:03

2 Answers 2

4

chmod -x setup.sh is used to take out the execute permission for the script. The right way to give execute permission for the script is:

chmod +x setup.sh

See man chmod.

Another thing: because of $@, probably your script expects one or more arguments. Check in the same directory where the script is, maybe you have there a README file to see the right usage. Or try to search for install instructions from where you downloaded it.

1
  • 1
    Again you have mentioned the same command without changing -x to +x.. ;) Commented Oct 10, 2013 at 19:28
4
  1. Open the file manager,
  2. Go to Edit->Preferences,
  3. On the Behavior-tab under "Executable Text Files"-section set the option to
    1. "Run executable text files when opened" or "Always ask"

Close it and try double clicking the file again

1
  • This fully depends on the file manager in use, OP didn't even name a specific file manager and neither did you.
    – dessert
    Commented Sep 21, 2017 at 21:34

Not the answer you're looking for? Browse other questions tagged .