I'm not exactly describing one problem, because I feel like solving it would be useless.

In the last 3 months I had a HUGE amount of problems with my headphone jack / speakers. I am using Ubuntu 12.04 on an Alienware M17x machine. Ever since I installed Ubuntu 3 months ago, a new sound problem came up every day, here is a short list :

  • Without an headphone jack, speakers work fine, but when I put my headphone jack in, sound still plays through my speakers; I have to go through pavucontrol to get the sound to go through my headphone jack (that is actually a very recurrent problem)
  • Sound is very low in the headphone jack (barely audible if I go in pavucontrol and put the headphone volume at 150% and the room is quiet).
  • Sound goes through both speakers and headphone jack when pavucontrol sets the output to headphone jack
  • Microphone input is very low (barely audible as in the previous problem) but the microphone outputs the same thing as my headphone jack is outputting
  • etc, etc, etc.

All these problems have one thing in common which pisses me off a lot : I was using my computer (I barely ever turn it off), all the settings were fine at some point, didn't touch anything, and then BAM problem. Very frustrating. I believe a cause might be because updates were done silently while I was using my computer but I admit I never actually noticed that the problems arrived right after an update. Otherwise I have no idea where these magical problems came from.

So here's the question : Why could I possibly get all these sound problems out of nowhere? I am not even bothering to ask how to fix them, because more often than not these problems were fixed by... ''dumb fixes'', i.e. go to some parameter in pavucontrol/alsamixer, switch it on then off (or the opposite) (in other words, doing nothing very special) and then BAM problem fixed. I am sick of these mysteries, as you can see.


sudo lsb_release -a:

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 12.04.3 LTS
    Release:    12.04
    Codename:   precise

sudo uname -a:

    Linux patrick-M17xR4 3.5.0-41-generic #64~precise1-Ubuntu SMP Thu Sep 12 16:50:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

sudo dpkg -l | grep alsa:

    ii  alsa-base                                    1.0.25+dfsg-0ubuntu1.1                           ALSA driver configuration files
    ii  alsa-utils                                   1.0.25-1ubuntu5.2                                Utilities for configuring and using ALSA
    ii  bluez-alsa                                   4.98-2ubuntu7                                    Bluetooth ALSA support
    ii  bluez-alsa:i386                              4.98-2ubuntu7                                    Bluetooth ALSA support
    rc  gnome-alsamixer                              0.9.7~cvs.20060916.ds.1-3                        ALSA sound mixer for GNOME
    ii  gstreamer0.10-alsa                           0.10.36-1ubuntu0.1                               GStreamer plugin for ALSA

The command sudo lspci | grep audio outputted nothing.

  • To get your problem completely it is so important to know which LTS version you are using, which kernel do you have installed and what drivers you are using.. To do so I want you to post the output of following commands: sudo lsb_release -a, sudo uname -a, sudo dpkg -l | grep alsa and sudo lspci | grep audio. reply.. – Saurav Kumar Oct 9 '13 at 17:58
  • @Saurav Kumar : Done! – Patrick Da Silva Oct 9 '13 at 19:20
  • sudo lspci | grep audio should show the output of audio device connected to your system for example mine shows this: 00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02). Execute this instead : sudo lspci | grep -i multimedia. Also after observing your output it seems that you are using kernel 3.5.x with older device drivers. I recommend you to install stable kernel like 3.8.x. – Saurav Kumar Oct 9 '13 at 19:34
  • For that I suggest you to visit this post and follow the steps precisely. You'll get a more stable kernel that suits well with Ubuntu 12.04.3 LTS. – Saurav Kumar Oct 9 '13 at 19:36
  • @Saurav Kumar : Still got nothing with sudo lspci | grep -i multimedia. – Patrick Da Silva Oct 9 '13 at 19:41

You can try this guide to help you get back the audio on your PC.

  • 1
    Hello and welcome to AskUbuntu. While technically this is an answer, it would be much preferable if you could outline the contents of the article for which you are providing the link. That way if the link would become unavailable, your answer would still be relevant. Take a few moments to review the help center page on how to make your answers more effective. – hmayag Apr 21 '14 at 11:24
  • This is a Windows guide, you have not even completely read the title of my question... – Patrick Da Silva Apr 21 '14 at 12:53

I tried everything to correct the "no sound" issue (Ubuntu 12.04.) I finally stumbled into an easy solution:

  1. Right click volume icon (upper right corner.)
  2. Click, "Play Sound Through"
  3. Test each option listed (e.g., the one that worked for me was "Analog Output/Amplify SD Audigy".)

Hope this helps.


I've found a way which will surely solve your problem of low sound in headphone.

  • First play any song so that you can feel the change in sound.

  • Run this command in terminal:


    if alsamixer is not installed then install it by: sudo apt-get install gnome-alsamixer

  • In terminal itself one interface will be opened as shown here:

(source: akamaihd.net)

  • Now use your -> arrow key to reach to option mic select. It is shown in red colour for which it is displaying Mic1 as value. For you it would display Mic2

  • Change it to Mic1 by using Up or Down arrow keys.

  • Your headphone sound should be increased. If not then try to change (increase/decrease) other values by Up or Down arrow keys.

Hope it would work for you this time.. Reply if you need any further assistance..

  • I have played with the alsamixer a lot. For instance since my computer is an Alienware M17x some people suggest I go in the alsa-base.conf file and change some line to options snd-hda-intel model=alienware. – Patrick Da Silva Oct 11 '13 at 3:24
  • I have tried many different options for "model = " (generic, no-jd, auto...) and they all seem to act on alsamixer in a very strong way (most of the time by changing the amount and type of dimmers that appear in the alsamixer as you displayed) but none of my options give me the exact same menu as you have ; namely, I don't have a "Mic 1/Mic 2" dimmer in my F3, only in my F4 (which is related to input, so can't possibly change anything about output)... – Patrick Da Silva Oct 11 '13 at 3:24
  • I partially solved my problem right now, in the sense that my output is working for some reason (I updated my kernel to 3.11), but my input is not working anymore, my microphone is producing white noise (again a new problem! yay...). Apparently by looking up forums I kept bumping into problems very specific to my model and all sorts of problem happen to people with Ubuntu on the Alienware M17x, all seeming to be related to incompatibility with the drivers... – Patrick Da Silva Oct 11 '13 at 3:27
  • I'll just go on my Windows partition when I want to skype with my friends I guess. 8) – Patrick Da Silva Oct 11 '13 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.