1

I am working out on an answer as given here https://superuser.com/a/623998/63915 I copied the windowsios to a usb drive

mount -t o loop win.iso /media/usb

but I see permissions problem all the files are owned by root:root and when I try to do do

sudo chown -R user:user /media/usb/

there is no change in permissions in files of USB I see following

 ls -l
total 3250
-rwxrwxrwx 1 root root     110 Oct  9 17:11 autorun.inf
drwxrwxrwx 1 root root       0 Oct  9 17:11 docs
drwxrwxrwx 1 root root   40960 Oct  9 17:35 grub
-rwxrwxrwx 1 root root     313 Oct  9 17:25 grub.cfg
drwxrwxrwx 1 root root 1208320 Oct  9 17:13 i386
-rwxrwxrwx 1 root root   45124 Oct  9 17:14 ntdetect.com
-rwxrwxrwx 1 root root    3204 Oct  9 17:13 readme.htm
-rwxrwxrwx 1 root root  260288 Oct  9 17:14 RUFUSLDR
-rwxrwxrwx 1 root root 1310720 Oct  9 17:13 setup.exe
drwxrwxrwx 1 root root       0 Oct  9 17:13 support
-rwxrwxrwx 1 root root  449797 Oct  9 17:16 txtsetup.sif
drwxrwxrwx 1 root root       0 Oct  9 17:13 valueadd
-rwxrwxrwx 1 root root      10 Oct  9 17:13 win51
-rwxrwxrwx 1 root root      10 Oct  9 17:13 win51ip

what went wrong here?

2
  • What is the output of df -T command? Oct 9 '13 at 12:45
  • I see my usb here /dev/sdb1 fuseblk 3914748 562760 3351988 15% /media/3AE27070E27031ED Oct 9 '13 at 12:50
3

chown fails because the mounted file system is fuseblk. So you are trying to write meta data to a file system which the file system does not support (cannot store). You can only change permissions and ownership on a Unix filesystem like ext3 or ext4.

If you want that mounted point with ownership applied to a specific user/group, specify at the mount time:

mount -o uid=username,gid=groupname /dev/sdb1 /path/to/mount

See also:

2
  • well I am not mounting that usb,when I insert USB to my laptop ubuntu automatically does that, i think this default behaviour is caused due to gnome-mount (udisks) working in backend is causing problems,because when I unmount the USB from nautilus window sudo fdisk -l does not show any kind of USB stick i.e. /dev/sdb1 should come here Oct 9 '13 at 13:44
  • @RegisteredUser Whatever you mount, I suspect that what you mount doesn't have a Unix filesystem format like ext3 or ext4. So, use mount with -o uid=username,gid=groupname option if you want that mounted point with ownership applied to a specific user/group. Oct 9 '13 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.