I recently bought a Dell Inspiron 15 3521 with Windows 8 pre-installed, and installed Ubuntu 12.04 on it.

The wireless is not working on it. I have tried a lot of methods available at the forums, but none seem to work.

I first tried by installing the Broadcom STA wireless driver. When that didn't work, I followed some steps given on a forum to remove it and install b43 firmware instead. That didn't help either.

Here are the relevant terminal outputs

sudo lshw -C network

       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 05
       serial: 74:86:7a:20:2d:48
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip= latency=0 link=yes multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:2000(size=256) memory:c0404000-c0404fff memory:c0400000-c0403fff

  *-network UNCLAIMED
       description: Network controller
       product: QCA9565 / AR9565 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:c0500000-c057ffff memory:afb00000-afb0ffff

and the output for

lspci -nn | grep 0280

02:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0036] (rev 01)

I have tried doing

sudo modprobe ath9k


sudo modprobe b43

without success.

  • We need more information to help you There is a trouble shooting guide here. This should give you enough information to edit your question with the relevant information we may need. Alternatively there is a trouble shooting procedure here Follow it and post all the output on Launchpad. – Warren Hill Oct 9 '13 at 10:24
  • Added more information. Please let me know if anything else is needed. Thanks – user1037704 Oct 9 '13 at 12:34

Your wireless device is covered in the driver ath9k but only in kernels 3.8 and later. Please see here: How to install Qualcomm Atheros AR9565 wireless drivers? You could update your 12.04 to 12.04.3 LTS which uses the 3.8.0-xx kernel or reinstall Ubuntu 13.04. You could certainly also compile the compat-wireless linked here.

  1. Go to www.dell.com
  2. In Support find (>Support for Home)
  3. In General product Choose product like.desktop,loptop,etc
  4. (EXAMPLE)If laptop click it and choose if its inspiron,alienware,etc
  5. (EXAMPLE)If inspiron click it and choose what its model like ,1000,mini 9,etc
  7. (EXAMPLE)In refine your result choose your operating system,category(wireless is problem click NETWORK),release date,and importance
  8. Find better file installation for your pc enjoy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.