I have an interesting issue with Ubuntu. I have a laptop that has one jack for line in/microphone and line out/headphones.

This the reason why I bought a spliter like below:

Splits one 4 pines jack into two jacks: micrphone and line out

I have an external studio microphone and headphones with the micrphone.

Case 1 (Working)

If I connect the micrphone of headphones to spliter that is inserted into my laptop, I can record my micrphone.

                   +------- LAPTOP

Case 2 (NOT Working)

If I connect another an external hardware (for example a piano) to the splitter, I cannot record anything... This is the issue. How can Ubuntu recognize if there is a headphones micrphone or an external hardware that is NOT a headphones micrphone?

PIANO  ------------+
                   +------- LAPTOP

...and the question is how to fix this? I want to record my piano using my laptop: through line in.

Would be the splitter an cause?

Do I really need a hardware that I don't have (like an USB recorder)?

Update: tested on Windows 8 on same laptop. It works properly... (Un)Fortunately, I am an Ubuntu user, so I will not go back to the Windows world... Still searching for a solution on Ubuntu.

My laptop model is Samsung NP300E5V-S01RO.

Update 2: Using alsamixer I managed to listen only the piano sounds, without other microphone sounds. This is how the current alsamixer configuration looks:

The information about my settings can be found here.

I still cannot select in Audacity (or other recording software) the recording device. It records from the internal microphone.

Update 3:

pactl list sources outputs this in the Ports section:

Case 1

Piano is connected:

analog-input-microphone-internal: Internal Microphone (priority: 8900)
analog-input-microphone: Microphone (priority: 8700, not available)

Case 2

An external microphone is connected:

analog-input-microphone-internal: Internal Microphone (priority: 8900, not available)
analog-input-microphone: Microphone (priority: 8700, available)
  • I'm sure that is not a "line in" but just a "mic in". Normally laptops do not include line-in. – Braiam Oct 31 '13 at 16:46
  • @Braiam Maybe that's true... How can I fix this issue...? I want so much to record a new song using my laptop... :-) – Ionică Bizău Oct 31 '13 at 16:59
  • One of the things i would suggest is trying another OS, even if it's a new version of Ubuntu, you don't need to install it, just run it from Live CD and see if it is able to resolve the issue. – v010dya Nov 29 '13 at 5:51
  • @Volodya I tried on Ubuntu 13.04 and there is the same issue... :-( – Ionică Bizău Dec 6 '13 at 11:40
  • @John Here's one possibility: Your microphone in is actually mono, but the piano is mono, but on a different channel. That hypothesis can be a theory if the software you are recording with assumes mono input, can you check that? If that's so you can try to swap left and right channel somehow, i can't find the way to do that correctly at the moment, though. Of course, this is only a hypothesis. – v010dya Dec 7 '13 at 4:34

By increasing that mic volume meter in alsamixer we only turn on the soundcards loopback feature, that is it redirects the mic input to the sound output internally, this stream is not accessible for softwares. (AFAIK) (But it confirms that the hardware receives the sound.)

You should try to increase all Capture meters in alsamixer to the maximum and make sure they are not muted, after this make sure that in pavucontrol the correct device and port is selected, and the mic input is not muted there, then try recording.

If it still not works, then it is likely that the problem is somewhere lower in the driver.

What you could still try is installing a newer alsa, maybe this problem is solved in a newer version. Other than that there are some tweaking tools for alsa here. Docs for it here. With the hda-jack-retask thing you are able to change your microphone input to a line-in one (or similar things), but I don't know whether that will help.

  • Giving you the bounty for the given help, but still the issue is not fixed. I opened it on launchpad. – Ionică Bizău Dec 26 '13 at 17:48
  • @Johnツ I' ve read the conversation at the bugreport. If you still don't know how to add hints, read this. E.g you do echo jack_detect=no > /sys/class/sound/hwC0D0/hints to disable the jack detections. Or in your case you can also try echo jack_detect=no > /sys/class/sound/hwC0D3/hints, but the former is the more likely to have any effect. – falconer Dec 26 '13 at 18:24
  • @Johnツ After adding that hint do echo 1 > /sys/class/sound/hwC0D0/reconfig or echo 1 > /sys/class/sound/hwC0D3/reconfig – falconer Dec 26 '13 at 18:27
  • Must I run the commands when the piano is connected? – Ionică Bizău Dec 26 '13 at 19:13
  • No. But these changes only last for one session, after reboot they are lost, so test it in that session in which you do the reconfig. – falconer Dec 26 '13 at 19:19

Maybe this little tip, which You can install from PPA will help:
[How To] Turn Headphone Jack to a Microphone Jack in Ubuntu | OMG! Ubuntu!

  • This sounds good, but unfortunately I get this error: "Failed to create file '/home/username/.pulse/client.conf.3A0Q7W': No such file or directory" when I try to Apply the settings. – Ionică Bizău Dec 6 '13 at 12:02
  • Create .pulse in your home directory, that should resolve the problem. – v010dya Dec 19 '13 at 13:19
  • Filed the bug here: bugs.launchpad.net/ubuntu/+source/alsa-tools/+bug/1262661 Please go there and select that it also happens on your machine. – v010dya Dec 19 '13 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.