I am trying to install latest cmake in my linux box and I am always getting the below exception -

userName@phx5qa01c-4e23:~/build$ wget http://www.cmake.org/files/v2.8/cmake-2.8.11.tar.gz
--2013-10-08 14:39:55--  http://www.cmake.org/files/v2.8/cmake-2.8.11.tar.gz
Resolving www.cmake.org...
Connecting to www.cmake.org||:80... failed: Connection timed out.

--2013-10-08 14:40:17--  (try: 2)  http://www.cmake.org/files/v2.8/cmake-2.8.11.tar.gz
Connecting to www.cmake.org||:80... failed: Connection timed out.

--2013-10-08 14:40:40--  (try: 3)  http://www.cmake.org/files/v2.8/cmake-2.8.11.tar.gz
Connecting to www.cmake.org||:80...

It is always retrying... Any thoughts?

Does anyone know what wrong I am doing here? Or is there any better way of installing latest version of cmake in my linux box?

userName@phx5qa01c-4e23:~/build$ uname -a
Linux phx5qa01c-4e23 2.6.35-22-server #33-Ubuntu SMP Sun Sep 19 20:48:58 UTC 2010 x86_64 GNU/Linux

12 Answers 12


Probably the server at www.cmake.org was just very busy. You could try again or download the file using your web browser.

There is however a much simpler way:

sudo apt-get install cmake

Update: commenters point out that "Ubuntu 12.04 is only shipping v2.8.7" and "14.04 is still shipping 2.8". That is for a reason: 12.04 and 14.04 are LTS releases of Ubuntu. LTS releases are intended to remain stable for 5 years, so they receive only security and critical updates, not the latest releases of packages. Normal releases come out every 6 months, and are therefore more likely to come with a recent cmake.

  • 3
    ubuntu 12.04 is only shipping v 2.8.7 of cmake with apt-get. The current release of version 2 is 2.8.12. I suggest you persevere with building it from source. Jun 16 '14 at 17:23
  • 91
    This is not the correct answer. The latest version is almost never on apt.
    – Senjai
    Feb 20 '15 at 6:09
  • 3
    14.04 still shipping 2.8
    – Stolas
    Mar 17 '16 at 9:22
  • 6
    This answer is wrong. The StableReleaseUpdates policy is not just for LTS releases. All Ubuntu releases, once actually released, only get fixes for security vulnerabilities or otherwise serious bugs. As shown here (and on Launchpad), even non-LTS releases haven't received new cmake versions. Separate backports for some packages do exist (but not cmake). Aug 4 '17 at 11:56
  • 16
    This answer is wrong because sudo apt-get install cmake does not, by itself, ever upgrade cmake to a newer version. This does not work on any Ubuntu release. If your answer is actually "upgrade your Ubuntu system to a newer release" then you may want to edit again to make that clearer. (That would not be a reasonable solution for many users, though, and often there is no released version of Ubuntu whose repositories have the latest version of cmake.) Aug 23 '17 at 13:55

The most common situation is when you want to install the latest version of cmake, but your Operating System's repositories are not updated. For example, in my case I have a laptop running Ubuntu 16.04, and when I executed the command sudo apt install cmake the installed version was 3.5.1; instead of 3.21.2 which is the current version at cmake.org.

How can I get the latest version?

Well, we can install it by following one of these methods: Using APT Reprositories, Building and Installing or Using binary files.

A. Using APT Repositories (Recommended for normal users)

Kitware now provides an APT Repository that supports Ubuntu 16.04, 18.04, and 20.04. So we can install it easily following these steps:

A-1. Uninstall the default version provided by Ubuntu's package manager and configuration by using:

sudo apt remove --purge --auto-remove cmake


sudo apt purge --auto-remove cmake

A-2. Prepare for installation

sudo apt update && \
sudo apt install -y software-properties-common lsb-release && \
sudo apt clean all

A-3. Obtain a copy of kitware's signing key.

wget -O - https://apt.kitware.com/keys/kitware-archive-latest.asc 2>/dev/null | gpg --dearmor - | sudo tee /etc/apt/trusted.gpg.d/kitware.gpg >/dev/null

A-4. Add kitware's repository to your sources list for Ubuntu Focal Fossa (20.04), Ubuntu Bionic Beaver (18.04) and Ubuntu Xenial Xerus (16.04).

sudo apt-add-repository "deb https://apt.kitware.com/ubuntu/ $(lsb_release -cs) main"

A-5. As an optional step, is recommended that we also install the kitware-archive-keyring package to ensure that Kitware's keyring stays up to date as they rotate their keys.

sudo apt update
sudo apt install kitware-archive-keyring
sudo rm /etc/apt/trusted.gpg.d/kitware.gpg

A-6. Finally we can update and install the cmake package.

sudo apt update
sudo apt install cmake

B. Building and Installing (Recommended for developers)

For this approach you need to install the GCC tools:

sudo apt update
sudo apt install build-essential libtool autoconf unzip wget

B-1. Uninstall the default version provided by Ubuntu's package manager as in A-1.

B-2. Go to the official CMake webpage, then download and extract the latest version. Update the version and build variables in the following command to get the desired version:

mkdir ~/temp
cd ~/temp
wget https://cmake.org/files/v$version/cmake-$version.$build.tar.gz
tar -xzvf cmake-$version.$build.tar.gz
cd cmake-$version.$build/

B-3. Install the extracted source by running:

make -j$(nproc)
sudo make install

B-4. Test your new cmake version.

$ cmake --version

Results of cmake --version:

cmake version 3.21.X

CMake suite maintained and supported by Kitware (kitware.com/cmake).

C. Using binary files (cmake-gui wont work well)

C-1. Uninstall the default version provided by Ubuntu's package manager as in A-1.

C-2. Go to the official CMake webpage, then download and install the latest .sh version in opt/cmake. Update the version and build variables in the following command to get the desired version:

mkdir ~/temp
cd ~/temp
wget https://cmake.org/files/v$version/cmake-$version.$build-linux-x86_64.sh 
sudo mkdir /opt/cmake
sudo sh cmake-$version.$build-Linux-x86_64.sh --prefix=/opt/cmake

C-3. Add the installed binary link to /usr/local/bin/cmake by running this:

sudo ln -s /opt/cmake/bin/cmake /usr/local/bin/cmake

C-4. Test your new cmake version as in A-4.


In 3.21.X the X represents the last part of the version that we defined as build. The build may change if cmake is updated. According to the official web page the Latest Release is 3.21.2. If you want the Previous Release 3.20.5 just replace the version and build parameters like this:

mkdir ~/temp
cd ~/temp
wget https://cmake.org/files/v$version/cmake-$version.$build-Linux-x86_64.sh 
sudo mkdir /opt/cmake
sudo sh cmake-$version.$build-Linux-x86_64.sh --prefix=/opt/cmake


For previous versions of CMake (3.19.7 <=) remember that file name has contanins an upper case L in -Linux-x86_64.sh and from version 3.20 it has a lower case l in -linux-x86_64.sh

  • 22
    The make install command need root privileges. The cmake --version command only works after open a new terminal because cmake is installed under /usr/local/bin/ by default, not /usr/bin/.
    – HD189733b
    Jan 22 '17 at 19:10
  • 1
    @Teocci, I have long tried to do this in various ways, and only your decision helped me. Thank you very much!!!)))))))
    – neo
    Mar 21 '17 at 13:49
  • 2
    This is not a solution to UPDATE but to INSTALL cmake. Try this command or google it to find a solution: sudo apt-get remove cmake cmake-data
    – Teocci
    Dec 26 '17 at 2:18
  • 1
    Note to also build the cmake-gui tool, add --qt-gui to the bootstrap command. Mar 12 '18 at 16:53
  • 1
    apt purge includes apt remove, so it's pointless to do sudo apt remove cmake; apt purge cmake Just do apt purge
    – gerardw
    Dec 16 '18 at 16:10

Kitware now has an APT repository that currently supports Ubuntu 16.04, 18.04 and 20.04

Install Instructions:

  1. Remove old version of cmake

    sudo apt purge --auto-remove cmake
  2. Obtain a copy of the signing key

    wget -O - https://apt.kitware.com/keys/kitware-archive-latest.asc 2>/dev/null | gpg --dearmor - | sudo tee /etc/apt/trusted.gpg.d/kitware.gpg >/dev/null
  3. Add the repository to your sources list

    a. For Ubuntu Focal Fossa (20.04)

    sudo apt-add-repository 'deb https://apt.kitware.com/ubuntu/ focal main'     

    b. For Ubuntu Bionic Beaver (18.04)

    sudo apt-add-repository 'deb https://apt.kitware.com/ubuntu/ bionic main'

    c. For Ubuntu Xenial Xerus (16.04)

    sudo apt-add-repository 'deb https://apt.kitware.com/ubuntu/ xenial main'
  4. Update and install

    sudo apt update
    sudo apt install cmake
  • 6
    Best solution as of today but the repository does not support the arm64 architecture. Nov 12 '19 at 18:01
  • 1
    Related links: cmake.org/download apt.kitware.com
    – wisbucky
    Feb 20 '20 at 19:28
  • unsecure repo error W: GPG error: apt.kitware.com/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 291F9FF6FD385783 E: The repository 'apt.kitware.com/ubuntu bionic InRelease' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details. Better use the PIP approach below
    – Bizmate
    Sep 3 '20 at 8:38
  • is the first step necessary? It should upgrade anyway right? Feb 25 at 11:59

First uninstall any cmake package previously installed. Then:

  1. Go to http://www.cmake.org/download/ and download the latest .sh installer

  2. Install it (for example) in opt/cmake by running

    sudo mkdir /opt/cmake
    sudo sh <installer filename> --prefix=/opt/cmake
  3. Add the cmake bin directory to your path: https://askubuntu.com/a/170240/359343

Installed in this way, cmake-gui looks a little bit horrible, if you find a way to fix it please feel free to edit this answer.

  • 13
    Add a link from /usr/local/bin/cmake to the installed binary. This way there is no need to change the PATH. sudo ln -s /opt/cmake/bin/cmake /usr/local/bin/cmake
    – Christian
    Mar 16 '16 at 14:30
  • 2
    This is the best answer.
    – SuB
    Nov 20 '16 at 9:59
  • 3
    really, this is most useful answer for initial question
    – amigo421
    Dec 1 '16 at 19:37
  • This gives me broken cmake-gui, which doesn't work over xRDP (prev version worked), and xRDP is the only way to access the server.
    – stiv
    Mar 28 '18 at 18:56
  • @stiv 1. Did you verify cmake after the installation is working, and that you have no other cmake version in your path? 2. Can you verify if you are using the cmake-gui provided in the installation, and not some older version? (To know the version, append --version to the command line)
    – Antonio
    Mar 29 '18 at 16:22

Just in case if someone need to install latest CMAKE in a docker image (like me..). In this case is 3.7.2, but you can check here https://cmake.org/download/ as already pointed out

#install latest cmake
ADD https://cmake.org/files/v3.7/cmake-3.7.2-Linux-x86_64.sh /cmake-3.7.2-Linux-x86_64.sh
RUN mkdir /opt/cmake
RUN sh /cmake-3.7.2-Linux-x86_64.sh --prefix=/opt/cmake --skip-license
RUN ln -s /opt/cmake/bin/cmake /usr/local/bin/cmake
RUN cmake --version
  • 5
    Nice, undocumented --skip-license option :) Jun 15 '17 at 4:22
  • 1
    @4LegsDrivenCat, --help shows this option and there is no other documentation. Jan 26 '20 at 4:09
  • 2
    @vulcanraven It was added to --help in v.3.10.0 on 2018-12-01. This answer and my comment refer to v.3.7.2. Jan 29 '20 at 8:34

I love the following way because you can get a recent version without much trouble.

Kitware seems to officially support a pip wheels release. So you can get latest cmake just by doing:

pip install --upgrade cmake

Here is the blog about it: https://blog.kitware.com/cmake-python-wheels/

  • 2
    Definitely the most useful answer! I wish I thought of that a year ago. Thanks! May 7 '20 at 20:05
  • 2
    This is probably the easiest one of all!
    – Chris
    Jun 19 '20 at 16:00
  • 1
    Thank you! This is much easier than alternatives.
    – RReverser
    Jul 17 '20 at 12:49
  • Happy to hear people find it useful. IMO it is the easiest and most reliable way. And it is also officially supported
    – Juan Leni
    Jul 17 '20 at 19:20
  • Thanks. Your steps as written exactly didn't work for me, but some minor adjustments and they did: On 20.04.1 LTS (Focal Fossa), I first had to install pip using apt-get install -y python3-pip. Then I could install Cmake using pip3 install --upgrade cmake Jan 3 at 7:24

You can find very recent versions of cmake through snap. For example, as of writing this answer, the latest version of cmake is 3.15.3, and snap has version 3.15.2.

sudo apt-get purge cmake
sudo snap install cmake --classic
  • 1
    Assuming a bash terminal, you might need hash -r afterwards to ensure the updated cmake binary is found. Aug 18 '20 at 8:56
  • @hertzsprung that is important, without hash -r, I cannot run cmake binary on terminal. Jul 17 at 11:18

You can also execute the following:

export fn=/tmp/cmake.sh && ls $fn && (echo "use previous $fn? Enter for yes, ctrl+d for no." && read) || (wget -O $fn http://www.cmake.org/files/v3.0/cmake-3.0.2-Linux-i386.sh 1>&2) && (cd /opt && sudo bash ${fn} && echo sudo ln -f -s /opt/cmake*/bin/cmake /usr/local/bin/cmake && cd -)

This script

  • fetches make 3.0.2 ** if it was already downloaded in this session, then you might reuse it if you did not finish the installation
  • then it copies makes link to the bin cmake.

For a Docker container, best run

RUN wget -qO- "https://cmake.org/files/v3.12/cmake-3.12.1-Linux-x86_64.tar.gz" | \
  tar --strip-components=1 -xz -C /usr/local

Adjust the version, if needed.


Remove old version using:

apt-get purge cmake

Download binary version of cmake archived in a tarball. You can use new version of cmake by adding its bin directory path to $PATH. An alternative solution is to extract tar.gz package and go to the directory made after extracting and run following commands:

cp -r bin /usr/
cp -r doc /usr/share/
cp -r man /usr/share/
cp -r share /usr/

The second method is the same as installation process which .deb package does!


Install the latest version of cmake from backports, where many latest versions reside. The particular backports depends on your current OS version. For example, running Debian Stretch, add the following to /etc/apt/sources.list

deb http://ftp.debian.org/debian stretch-backports main

Then install from this backport, aka:

sudo apt-get -t stretch-backports install -y cmake

qwr's answer to use snap can be good but if you want something even newer, cmake makes building a DEB from source easy. The following assumes you have a recent cmake already installed. Ubuntu 18.04's apt install cmake will definitely work here.

sudo apt-get build-dep cmake
git clone http://www.cmake.org/cmake.git
cd cmake
git tag
# find the highest tagged release value (hint, rarely at the bottom)
git co tags/<highest tagged release value>
mkdir build
cd build
cmake ..
cmake --build .
cpack -G DEB
# you built a single deb that has what Ubuntu provides as two debs, the binary
# deb and the additional architecture independent data files
sudo apt remove cmake-data
sudo dpkg -i cmake-<highest tagged release value>-Linux-x86_64.deb
  • Now run the command man cmake and you will see one more reason that apt outshines the install from source method 99.999 % of the time.
    – Nate T
    Sep 12 at 9:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.