3

I've just installed Ubuntu in a dual boot Linux/Windows setup on an ageing Dell Inspiron 1520. After searching answers on here I got past the Broadcom wireless card/no connectivity issue and the missing splash screens/nvidia proprietary drivers issue, but this one has me beat.

My wireless router is broadcasting its SSID correctly - it is definitely not hidden. The router is set to broadcast the SSID and other devices pick it up fine. However on boot Ubuntu shows no available networks for connection. After poking around I managed to set up a connection manually via 'Connect to hidden wireless network'. This works fine until a reboot, at which point I have to reconnect manually (the connection I set up remains in the drop-down list). If I disconnect without rebooting, the network remains listed under wireless networks and I can reconnect with a single click. I've tried changing all available wireless switches (wifi catcher etc) in the bios and all combinations of the 'Connect automatically' and 'Available to all users' tickboxes in the 'Edit connections' dialogue, but no result.

This is more a convenience thing than a deal breaker but any suggestions would be gratefully received.

  • ARE the router SSID options set to broadcast ?? – damien Oct 8 '13 at 23:54
  • Yes they are (just double-checked). Question updated to note that. – eyeserene Oct 9 '13 at 16:31
6

I was also having this problem with 12.04. Here are the steps I took to fix the problem.

  • Had to install firmware-b43-installer and remove bcmwl-kernel-source.

    sudo apt-get install firmware-b43-installer
    sudo apt-get remove bcmwl-kernel-source
    

    Reboot

At this point my wifi light became active and I could connect if I used the "connect to hidden network" and typed in the name and passcode.

  • Once I was connected to the wireless network I installed a package called WICD. Now, I only installed this package ... I DID NOT configure anything or remove network-manager.

    sudo apt-get install wicd
    

    Reboot

  • After the reboot, it found my network and automatically connected. I'm not sure why this worked, but I do know that some other packages were installed with wicd. Maybe one of these packages fixed the problem? Not sure, but again I DID NOT remove network-manager after installing WICD.

This has solved the problem for me .... hope this helps you.

  • I used this work around on my Ubuntu 14.04 (DELL Inspiron N4010) and it solved my problem. I just run the first two commands: sudo apt-get install firmware-b43-installer sudo apt-get remove bcmwl-kernel-source – PHP Learner Sep 17 '14 at 10:53
  • It is also worked for me on ubuntu 12.04. But After following this step, I had to install "Broadcome STA wireless driver" from additional drive panel in setting. – Piyush Aghera Apr 29 '15 at 6:27
0

I found that I was having similar problems, but also with other devices as well. Sometimes they could connect, but most often could not.

I disabled the 5Ghz option on my WiFi router seemed to take care of the problem. It only broadcasts now at 2.4Ghz. I don't have a reasonable explanation for this, but it did solve my problem.

Obviously, if you don't have access to your router's settings this solution won't work for you.

I am running Ubuntu 16 with a Dell Inspirion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.