5

I have a few CDs lying around that I'd like to rip and encode in MP3 format using Rhythmbox. After installing the ubuntu-restricted-extras package, one of the options that shows up in Rhythmbox's preferences under "preferred format" is "CD Quality MP3," but from the encoder options it appears that it uses a constant bitrate.

I'd like to set up an Audio Profile to encode at a variable bitrate (VBR) at a reasonably high quality. What options do I need to use under "gstreamer pipeline?" Or alternatively, is there a more discoverable way to enter encoding options than entering command-line options into Rhythmbox?

4

Just so we're talking on the same page, the pipeline used by this encoding target looks like the following on my system:

audio/x-raw-int,rate=44100,channels=2 ! lamemp3enc name=enc target=0 quality=6 ! xingmux ! id3v2mux

You can learn about each of the elements in the pipeline with the gst-inspect-0.10 tool. For example, to learn about the MP3 encoder used here, you could run:

gst-inspect-0.10 lamemp3enc

Among other things, this will tell you about the various properties supported by the element and their defaults. This tells me:

  • encode using variable bit rate (cbr=false from defaults)
  • the encoder has been set to optimise for quality rather than a target bitrate (target=0)
  • uses a VBR quality setting of 6 (quality=6)
  • uses the standard quality of the LAME engine (encoding-engine-quality=standard from defaults)

So you should already be getting VBR output from that pipeline. If you want higher quality, lower the 'quality=' number (0-10, 0 is the highest quality) and perhaps add encoding-engine-quality=high.

1
  • Awesome. Thanks for breaking it down for me. I'm not sure what my original pipeline was because I stupidly edited it instead of adding a new one, but it seemed to be CBR from reading it. Two small hitches in this answer though: 1) for LAME, lower numbers == better quality and 2) I had to restart Rhythmbox before my new Audio Profile showed up in the list. – Ryan Apr 17 '11 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.