Here's my setup:

  • Dual booting with Windows 7 on /dev/sda1, Ubuntu 13.04 on /dev/sda5 (home on /dev/sdb if it's relevant)
  • Coming from using Ubuntu 13.04, 32-bit version for a few months

I need to install Ubuntu 13.04, 64-bit, though I've been having some problems doing it. I'm installing off of a USB key I created using unetbootin. The live image seems to work correctly. I've attempted custom installs and letting the installer choose the partition layout but it does not seem to affect the problem.Here are the other problems I've run into in order of occurrence:

So now I'm running into this problem:

13.04: Kernel panic - not syncing: No init found

The stock answer to this seems to be some sort of file system problem. I've fsck'd all the things I know to fsck (/dev/sda5 and the home drive) but it reports the file system is clean. I've checksummed the disk image I'm using and it checks out as well.

The panic message recommends setting the init= option of the kernel command, which I've tried to do (/sbin/init and even dropping a copy of init in /boot just to see if anything different happens) to no avail as well.

I've exhausted what I know to do, so just to be pedantic I'm trying an install from optical media as well which I can't report on yet. I don't know grub that well but I am still a little worried about the i386-related error message, though it definitely looks like the 64-bit image of Ubuntu is installed.


Installing from a DVD ended up being the fix for me, though that may not be the best solution or even an option for some.

  • Same situation (ubuntu 14.04 x64, unetbootin, usb flash) # update-initramfs -u in chroot'ed environment does not help – user272287 Apr 22 '14 at 4:38
  • @CTAC I'm curious if installing from CD or using some unetbootin alternative fixes the problem? Though I suspect since you are here you may have already tried it. – OEP Apr 22 '14 at 16:06

Your initramfs is bad. Regenerate it with sudo update-initramfs.

| improve this answer | |
  • @Braiam, no idea what you mean. – psusi Oct 8 '13 at 14:24
  • @Braiam, I have no idea what the OP did, therefore no idea how it got damaged or how to prevent it in the future. The only thing I can tell from the question is that it is damaged. – psusi Oct 8 '13 at 14:56
  • 2
    I wasn't able to update this question until just now but installing from a DVD solved my problem. I'm not sure if initramfs was the culprit or not, but maybe for future visitors, would this have worked from a LiveCD? For the affected system I was not able to get any kind of prompt except grub. – OEP Oct 8 '13 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.