1

I've recieved a couple of errors while trying to install 12.04.3 LTS (64 bit) on my Lenovo Thinkpad T510 i5 laptop.

The first error was, ERROR!!! Input/output error during write on /dev/sda I've encountered this a few times so I've tried both of either clicking ignore and clicking Retry. If I click ignore then I eventually get to the second error described below.

Second error:

 The creation of swap space in partition #5 of scsl1(0,0,0)(sda) failed

Once this error is recieved I am recieve no further instructions from the installer, as if I never tried to install to begin with. And then on future attempts to boot from USB thumbdrive I have to manually (thinkpad button + F12) tell the machine to boot from USB or a blinking white line will just stare at from the corner until I forcibly power down.

But back to the original issue; it probably is important to note that I recently removed a Toshiba hard disk from an Imitation external hard drive and installed it in the Thinkpad. The external hard drive was working fine before so I'm inclined to think the hard drive in the Lenovo should still be functioning.

I tried to use the Ubuntu supported SMART technology but I'm not sure if this Toshiba hard disk supports it. If it's important I can post the model #; all I remember is that it operates at 5400 rpm and can hold around 320GB.

I'm thinking about using the Thinkpad's hard drive test utility but wanted to see if I could get any info from this Ubuntu forum in parallel.

This is my first attempt at using/installing Ubuntu so please take that in consideration when responding with recommendations. I'm a quick learner though so also don't feel like you have to leave out in detail.

Thanks in advance to any insights anyone has to offer.

  • I have not heard of any drive made in the last 10 years that doesn't support SMART. You said you tried, but did not say how or what happened. Most likely the drive is dieing, but checking the SMART status in the disk utility will confirm. – psusi Oct 8 '13 at 2:04
  • possible duplicate of "errno 5 - input/output error" when trying to install – Eric Carvalho Aug 19 '15 at 13:19
1

The error "The creation of swap space in partition #5 of scsl1(0,0,0)(sda) failed" is probably because of something to do with your partition settings. If you are dual booting make a note of which drive your windows and other important are installed and either format or delete partitions that you may have created erroneously. Use Gdisk partitioner to view which partitions need editing.

Also remember to allocate enough swap space when installing.

| improve this answer | |
1

I just answered 2 questions and they apply to your situation.
You need to properly partition the hard drive. The message you posted
tells me it is not right.
So here is a copy of my reply about how to partition the drive to install ubuntu

It is possible that your hard drive is not formatted.
You need to start Ubuntu again from your CD or flash drive
but do not try to install it yet! When you get to the desktop
you need to start a program called Gparted. If it is not there
then open up package manager and install it.

Now run Gparted and see if it detects your hard drive.
If it does then delete any partitions that are on it first.
Then click Apply. Now you need to create a new partition table
so you will click on Device (at the top of Gparteds screen)
then click on Create Partition Table and choose the entire drive
for a new partition. Then click Apply again and you should see
that the drive is correctly partitioned. This will make it easy
for ubuntu to see it. Now the Ubuntu install can go ahead.

However, I think you need to read my other reply as it tells
how to set up a good partition table for ubuntu to run on.

Hello
It would be easiest to just start from the beginning so lets do that, okay?
First, boot to your USB and let Ubuntu start a live session. You will see an icon on the desktop that says Install Ubuntu on your desktop. Launch (click on) it.
When you get to the screen where it asks you if you want to replace an existing install or install next to it or Something Else, choose Something Else.
Now you will see a screen that will let you see the hard drive you want to install to. Make sure you choose the correct drive you want to install ubuntu on! On that screen you will need to first delete any existing partitions so you can start fresh.
Start at the bottom of the listed partitions and right click on each one and choose Delete. After you have done this to all the partitions, click on Apply. When you have deleted everything your drive will show as completely unallocated space! Sometimes some partitions cannot be deleted right away so delete all you can at first and click Apply, then start over from the bottom until they are all deleted.
Now you want to create the necessary partitions for you to install Ubuntu.
Create the following partitions.
1. a boot partition /boot and give it 250mb of space, choose ext4 for the format.
2. a root partition /root and give it 15000mb of space and ext4 format
3. a swap partition /swap and give it 4096mb of space (it will format to swap)
4. a home partition /home and give it the rest of the space and format it to ext4.
Now just finish the install and it will run beautifully.

| improve this answer | |
  • The only device that shows up in the Gparted GUI window is my USB thumb drive. My Hard Drive does however show up in the "Disk Utility." And I'm not sure what I was thinking before but the SMART status is visible and it says, "Disk has a few bad sectors," 1994 bad sectors based on the disk utility. Is it advisable to use the disk utility to partition and format the drive as you recommend to do with Gparted? Also, I see via the Disk Utility that my thumb drive is mounted as /dev/sda while my hard drive is mounted as /dev/sdb . I don't know why during install a write to /dev/sda was occurring. – Robert Oct 8 '13 at 3:25
  • YES, by any means, partition it. Just make sure you partition your hard drive and after that it should point to it correctly. – Ronshere Oct 8 '13 at 9:44
  • I've rebooted since receiving your comment to partition by any means. I was unsuccessful at formatting and partitioning the drive with the Disk Utility. I am now receiving the error message, "Daemon is inhibited." Also, I mentioned in my original post that the Disk Utility told me that SMART wasn't supported for this Toshiba hard drive. Then I said in a later post that the SMART status was now present and telling me that the drive had bad sectors. Now, after rebooted, it's telling me SMART not supported again. I'd partition with another machine but don't have another machine. I'm at a loss. – Robert Oct 12 '13 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.