2
root@ip-10-194-97-94:~# apt-get install uwsgi

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
  uwsgi: Depends: uwsgi-python2.6 (>= 0.9.6.5-0ubuntu1~lucid1) or
                  uwsgi-python3.1 (>= 0.9.6.5-0ubuntu1~lucid1)
E: Broken packages
  • 1
    what repository does uwsgi belong to? – steabert Apr 16 '11 at 18:42
1

uwsgi is not in the default repositories. You need to add a PPA (Personal Package Archive) and update your sources:

sudo add-apt-repository ppa:uwsgi/release
sudo apt-get update
sudo apt-get install uwsgi
1

uWSGI is not well packaged. You must either install uwsgi-python or uwsgi-python3. All of the other packages are marked as Conflicts, which is completely confusing and assuredly wrong.

1

Original text: A melhor forma seria

Translated using Google Translate: The best way would be

sudo add-apt-repository ppa:uwsgi/release
sudo apt-get update
sudo apt-get install uwsgi-python

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.