37

When I boot up my my newly installed copy of Ubuntu on my custom rig w/4GB DDR3 RAM and a 3 Ghz Intel Core i7, it takes about a minute and a half at the purple loading screen, and then after logging in it takes a while for the icons to show up on the screen. This computer could run and boot Windows 7 faster, so i have a problem here.

  • 1
    probably it's waiting for something and times out, can you check /var/log/messages after you booted? It has a log with the times from during the boot sequence. – steabert Apr 16 '11 at 19:35
  • 4
    You might try running bootchart. Also see this answer – belacqua Apr 16 '11 at 20:19
  • @belacqua, it seems the bootchart Ubuntu packages are not available for download anymore bootchart.org/download.html – Marco Lackovic May 23 '12 at 11:06
  • 1
    In Ubuntu 12.04 there is an alternative application to bootchart called pybootchartgui available in Ubuntu Software Center. – Marco Lackovic May 23 '12 at 14:53
  • 1
    With SSD or without SSD? – BigSack Jun 18 '12 at 8:36
22

Easiest would be to open the terminal and then write "dmesg" to look for gaps as Peck proposed. The output would be less verbose than the messages one. You will see the time stamps within "[]" brackets.

This is clearly a bug. With that system you should not have a boot longer than ~10 seconds.

| improve this answer | |
  • 7
    I did $dmesg and I get bunch load of output now what to look for? – Gaurav Agarwal Jan 3 '15 at 11:18
  • 2
    Look for the lines with a big difference of timestamps value. For example, in my case I've noticed that before the line cgroup: new mount options do not match the existing superblock, will be ignored the system was loading for 10 seconds but this one step took the whole 90 seconds which is bad (caused by wrong swap partition id). So that's the way to nail down your problem. – Nicolas Ivanov Jul 30 '16 at 17:20
  • What do you do when you isolate the problem? I don't know anything about partitions or booting in general – Matt G Nov 12 '17 at 16:03
19

I would check System > Administration > Log File Viewer > Messages. It may show something lagging or stalling before it backgrounds the process while booting. The log has time date stamp with seconds. Look for excessive gaps in the seconds,, etc. and repeated items. If your box has been booted over successive days you may be able to compare previous logs.

| improve this answer | |
  • Thanks! Helped me find an issue where the swap partition was moved on a disk, so the UUID for it was no longer valid. Can't imagine how I would have figured that out without this tip – Zane Hooper Jul 16 '16 at 0:13
  • 2
    Now that this System > ... > Messages menu structure does not exist any more in recent Ubuntu versions, how can I reach the same UI? I found a log viewer, but it doesn't have a "Messages" section. – Dan Mirescu Sep 10 '18 at 8:50
7

Install bootchart and pybootchartgui and upload the .png file in /var/log/bootchart.

Anyway, it'll show you the entire procedure from system up till the complete boot. Disable time-consuming but non-required packages. Install the application bug for this.

All these packages can be installed this way:

sudo apt-get install bootchart pybootchartgui

Also run the command:

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

Now open 'Startup Applications' and uncheck whatever you don't wish to load during boot.

| improve this answer | |
5

You could start by disabling some services at startup like Bluetooth and Remote Desktop and Gnome Login Sound.

Go to System > Administration > Startup Applications to de-select the items for running at startup and see if you notice any change in boot up time.

| improve this answer | |
4

I solved this problem by entering the BIOS and then disabling the ACHI SATA controller option and setting the SATA control in "compatibility" mode. It worked just fine for my Toshiba NB200!

| improve this answer | |
3

Believe it or not its the text output.

open a terminal and run:

sudo nano /etc/default/grub

change the line:

GRUB_CMDLINE_LINUX_DEFAULT=""

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

run:

sudo update-grub2

It shaved 10 seconds off my 15 second boot time.

| improve this answer | |
  • quiet is great but one sometimes needs to see what's going on on startup and notice any immediate errors. – NelsonGon Sep 4 '19 at 5:34
1

Uninstalling hp-lip 3.14.1 helped with the same problem. I used Ubuntu-Tweek to clean everything out.

I'm using Ubuntu 12.04. hp-lip was required for my printer (HP Envy 4500).

| improve this answer | |
  • It is crazy, but I think it solved my problem. I had a terrible delay (It felt like minutes) to load the desktop at start up. I did two things: 1) uninstall hp-lip, 2) empty my overfilled rubbish bin. One of those things made it happen. Now almost immediate start up of desktop :D – loved.by.Jesus Oct 12 '19 at 23:19
-2

in BIOS menu, change SATA controller to compatible. worked on lenovo z500. it's not miracle but it boosts startup considerably. also kill ALL the startup applications. Desktop environments do not matter at all, at least not that much. on my computer Unity, Gnome shell and XFCE take almost the same time to start up so don't put a lot of effort into changing your DE.

| improve this answer | |
  • 2
    SATA mode should be in AHCI for performance. Changing it to IDE-compatible only slows it down for compatibility with older braindead operating systems. I don't see why this would be useful. – gertvdijk Oct 14 '13 at 20:26
  • 1
    That would slow even more the boot. – Braiam Oct 14 '13 at 22:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.