13

When trying to run meld on Ubuntu Desktop 13.04, I get the following error:

$ meld

(meld:1509): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Failed to connect to socket /tmp/dbus-EQeHnPP7h5: Connection refused
Traceback (most recent call last):
   ...
glib.GError: No D-BUS daemon running

I am running as a non-root user, with a X11 forwarding through PuTTY/SSH to Xming.

24

This bug pointed me to two ways to fix it, of which I used:

eval $(dbus-launch --sh-syntax)

export DBUS_SESSION_BUS_ADDRESS
export DBUS_SESSION_BUS_PID
  • Just tried and it works on 14.04 – Antony Aug 5 '14 at 2:19
  • I still get many GConf warnings (failed to connect), but not the same reason (was "Connection refused", it's now "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." Emacs now starts reasonably fast in my ssh -X session, at least. – Gauthier Oct 10 '14 at 12:44
  • you saved my day :) – Sagar Sakre Mar 2 '15 at 6:57
  • Works on 16.10 as well, but I just run it as sudo dbus-launch --sh-syntax – Marcin Nov 18 '16 at 23:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.