0

Yesterday I was using Kubuntu 13.10. I had a problem using my Intel and Nvidia graphics cards. I thought this was a KDE problem, so I changed distros to Xubuntu. After the installation I installed Steam and it was working. I was happy. I got this error

ERROR: Could not open display :8   

Next I installed an update, and after the update I was trying to install nvidia-prime but after restarting lightdm didn't start. I reinstalled Xubuntu, installed an update, and install the nvidia-319 driver and bumblebee using the following commands:

sudo apt-get install nvidia-319 nvidia-settings-319
sudo apt-get install bumblebee linux-headers-generic

I restarted the computer and installed Steam. After Steam started I got an error exactly like the error I got before on Kubuntu. While using the Intel card and running Steam I got this error:

ERROR: Could not open display :8 

Nvidia running using bumblebee was giving me a primus error.

I reinstalled the operating system again and installed updates and Steam is working. How do I install Bumblebee without getting a graphic cards problem?

  • Official Optimus support is out for Linux. – Naveen Oct 7 '13 at 12:38
  • Optimus support? On 13.04 i was using bumblebee. What change now about this support? Nvidia-primus is not working for me. – set4812 Oct 7 '13 at 12:44
  • @set4812 Bumblebee by default uses nvidia-current driver. If you are using nvidia-319 you need to change /etc/bumblebee/bumblebee.conf and restart Bumblebee. – Salem Oct 7 '13 at 14:03
0

Remove all Bumblebee packages you have installed (along with the nvidia319). Start afresh. Specific instructions for Ubuntu 13.10 version are as follows: From the Bumblebee on Ubuntu installation wiki-

"You need to open your terminal and enter the commands below.

If on 12.04.3, replace linux-headers-generic with linux-headers-generic-lts-raring.

sudo add-apt-repository ppa:bumblebee/stable

Enable the Universe and Multiverse repositories (for bumblebee and nvidia packages respectively).

sudo apt-get update

Install Bumblebee using the default proprietary nvidia driver for 12.04 - 13.04 :

sudo apt-get install bumblebee bumblebee-nvidia virtualgl linux-headers-generic

***And for 13.10 :

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic
Reboot*** "

First purge the nvidia-319 you have OR update it ( I didn't do either because Bumblebee handled it for me ). Then follow the highlighted instructions for 13.10. Then REBOOT( very important ). If it shows an error like :"Not added to the Bumblebee group". Then add yourself using groupadd

This should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.